
<!DOCTYPE html>

<html lang="en">
<head><meta charset="utf-8" /><meta name="robots" content="default, follow" /><meta name="googlebot" content="default, follow" /><meta name="language" content="english" /><meta property="fb:pages" content="495043790511" /><meta name="msvalidate.01" content="1CBFE669AE929C594B3B0E1BF4E454CE" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><title>
	Billy Eichner Calls His Upcoming Film &#39;The Gay &#39;War Of The Roses&#39; You&#39;ve Been Waiting For&#39; | On Top Magazine | LGBT News & Entertainment
</title>

   

          
        
      <script type="text/javascript">
          window.onload = function () {
              var myDiv = document.getElementById("MainContent_FormView1_lblBody");
              var myThirdPar = myDiv.getElementsByTagName("p")[3];
              var newDiv = document.createElement("div");
              newDiv.className = "adInjector";
            
              var newImg = document.createElement("img");
              newImg.src = "http://www.tqlkg.com/image-7388032-11098646-1400274404000";
              newImg.height = "250";
              newImg.width = "300";
              newImg.alt = "2Xist Shop";
              
              var newLink = document.createElement("a");
              newLink.href = "http://www.anrdoezrs.net/click-7388032-11098646-1400274404000";
              newLink.appendChild(newImg);
              newDiv.appendChild(newLink);
              myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

              


              //var newGANad = document.createElement("SCRIPT");
              //newGANad.src = "http://tag.gayadnetwork.com/ttj?id=1231478";
              //newGANad.type = "text/javascript";
              //newDiv.appendChild(newGANad);
              //myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

          }
       


      </script>
      
    <link href="../../favicon.ico" rel="shortcut icon" type="image/x-icon" /><link rel="alternate" type="application/atom+xml" title="atom" href="http://feeds2.feedburner.com/ontopmagazineheadlines" /><link href="../../Content/bootstrap.min.css" rel="stylesheet" /><link href="../../Content/Site.min.css" rel="stylesheet" />
   <script defer src="https://use.fontawesome.com/65f232d7af.js"></script>
    <script type="text/javascript" src='/Scripts/jquery-2.1.4.min.js' ></script>
    <script src='/Scripts/bootstrap.min.js' ></script>
   
    

<script>(function (i, s, o, g, r, a, m) { i.GoogleAnalyticsObject = r; i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments) }, i[r].l = 1 * new Date(); a = s.createElement(o), m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; m.parentNode.insertBefore(a, m) })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga'); ga('create', 'UA-823485-1', 'ontopmag.com'); ga('require', 'displayfeatures')
    ga('send', 'pageview', {});</script>

<meta name="description" content="Out comedian Billy Eichner will star in an upcoming Amazon comedy film about a gay male couple getting divorced" /><meta name="keywords" content="gay film, ex-husbands, billy eichner" /><link rel="image_src" href="http://www.ontopmag.com/images/ArticleImages/Billy_Eichner_attitude_dec_2018.jpg" /><link rel="amphtml" href="http://www.ontopmag.com/article/50648/Billy_Eichner_Calls_His_Upcoming_Film_The_Gay_War_Of_The_Roses_Youve_Been_Waiting_For/amp" /><link rel="canonical" href="http://www.ontopmag.com/article/50648/Billy_Eichner_Calls_His_Upcoming_Film_The_Gay_War_Of_The_Roses_Youve_Been_Waiting_For" /><meta property="og:description" content="Out comedian Billy Eichner will star in an upcoming Amazon comedy film about a gay male couple getting divorced" /><meta property="og:type" content="article" /><meta property="og:title" content="Billy Eichner Calls His Upcoming Film &#39;The Gay &#39;War Of The Roses&#39; You&#39;ve Been Waiting For&#39;" /><meta property="og:url" content="http://www.ontopmag.com/article/50648/Billy_Eichner_Calls_His_Upcoming_Film_The_Gay_War_Of_The_Roses_Youve_Been_Waiting_For?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><meta property="og:image" content="http://www.ontopmag.com/images/ArticleImages/Billy_Eichner_attitude_dec_2018.jpg" /><meta property="og:site_name" content="On Top Magazine" /><meta property="fb:admins" content="495043790511" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@ontopmag" /><meta name="twitter:title" content="Billy Eichner Calls His Upcoming Film &#39;The Gay &#39;War Of The Roses&#39; You&#39;ve Been Waiting For&#39;" /><meta name="twitter:description" content="Out comedian Billy Eichner will star in an upcoming Amazon comedy film about a gay male couple getting divorced" /><meta name="twitter:image" content="http://www.ontopmag.com/images/ArticleImages/Billy_Eichner_attitude_dec_2018.jpg" /><meta name="twitter:url" content="http://www.ontopmag.com/article/50648/Billy_Eichner_Calls_His_Upcoming_Film_The_Gay_War_Of_The_Roses_Youve_Been_Waiting_For?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><script type = "application/ld+json">{ "@context":  "http://schema.org", "@type": "NewsArticle", "headline": "Billy Eichner Calls His Upcoming Film 'The Gay 'War Of The Roses' You've Been Waiting For'", "datePublished": "8/9/2021 7:48:00 AM", "description": "Out comedian Billy Eichner will star in an upcoming Amazon comedy film about a gay male couple getting divorced", "publisher": {"@type": "Organization", "name": "On Top Magazine", "logo": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/icons/OTM_logo_for_AMP.jpg", "width": 372, "height": 58}}, "image": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/ArticleImages/Billy_Eichner_attitude_dec_2018.jpg", "height": 400, "width": 600}}</script></head>
<body>

 

    <form method="post" action="./Billy_Eichner_Calls_His_Upcoming_Film_The_Gay_War_Of_The_Roses_Youve_Been_Waiting_For?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3a+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" id="ctl01">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="aX+I5URjBTnm00IxjVoxKtsQH2wvVDrZgfEQLYsoNq0aX8Gb3dHcXS+TblSaZ4V2PFsnmo8ra18SSabSmD+y/dZad4AsaULSEdIK44FFJ1i6fapgFTSAWzk9Y9vErsdCYHKGmzpS3GKsor2rGlP6K92FPlpO+gRLKU6LpQCMQ/+9ZjWCCA/sXIQlnDz7DEK+iBuWz6i2Ds9uscCEWWevCkOmjftW4rsvekyud/H1QatcK0KwR2Po4Pm5o79mhx76yFeu40AQaZxLIxBqwo8/v8iB0whBhuKYEIOYkPKbqXazcPk0Ma9uvrgaSttzgqWUKGCahmwNWSUGhbq0fXXJKuMY6cWx353zOOcUqNWCf50k89Hb4DWjSjHZoOpSJ4hJW/BZonf8OgFrb3q5Ul8MIt6dbdX84I+VkSSlZgncp0rSa7zXBscv22+fwiGBq9beYfwB1h0dktbuFP4NRH1ufET9qAZ9nk+nP62TUdsBImejMqL6rtD6o0ZNVpHyGldMhFMemBXMapMsY2IMNjohxxeLOxb4H3o0xnV5Rkh+3J5946n1UVzgHzcpe+TzFDPXBc2MwACWyyYV2QD41ZxfttUQ+bgwvy9TgVsdDLW+z5jiVd9bNLc7LU/xdOpm4WNJAvq7WYFaTjTBAIKvre1dyaxlrA+16fWDiU6sZ3vaUnhJiwEc7nz3i10oN4pIN2JEUxZLZAi/Cov2/jwE6Pel20QwFHjbVBMyu/Ec2FCfzkcMJYYEWX28/YdUZus18q/B3XiU2mFxjga6+4cE7l76Lsozf3b7YBOuvqRZjqJem6mXKQg8xOOLFhyC7Bxe6mJhEOK2M4cdLnstySVbk6A0BEMQHkD05SfCSx3WpD5Y7AcCusuMeNVdpqEe4BKRisL5xQnVIbWZofSJdofrfnv3d5mvUvDlwWqebgYa83JkJ29+dnzLlqsM9exv9e2G/B8F2E9zOrbdtYGSBJiW8TbtasHtlxbhnf9YHuh1IyIdC7U9U1yGTQY3k3SinhNYg7DdOp1SVzxeZQPZka3Tod6TMUxnER5nmPLCjC4E/w2OKMmD+05nmUm8w4VD9vIG0HXW+WckmEcV1G34Vx+bMaw7NkZ/NKCUdQ4ytT+yNyL3SQgPxRJfxqof+ZQtYlW2husyH4Zbu10XyFW57lo/Vi3Ia/49mAZ5IcyU2ih6C22KmRp9O1x1bvCxipBe+ibb+7Tcufx+c4yhVDxx6KZ2Jvo45nw1e8wVOYUP6fUz1JYdvGzAnh5nWTMiB0MWTgpzxwCvgvkMlvGduXcCwUidsTUcQUGlvt4hlNZC+3Psf5by8lWKcqQUWPPXlH/+jcqYrCaX2kxceulsOjNVlgLJXBq5AALz4nIHZfav4eZWN900PUouTzPzAOjbc62QX4hyQ6uFZVzXdS2qCShfIygPFGxLe7xONxi7gpsKG96HEGbsOnb+ii0XfOdyxjl+si5DkoEuBmKQ5J/uPpbvMKy8Gy2lfXZw8mHB/rTH8moruBMEkQgBkrqWcEOJoZjU1cZxRzZoDBkH3CsBcxNBB7yaNywt8GNHrY1Va2/2YHwmxHVbN8c4pk+f/tzw/FHT0rzRa3zGzULaZIAv/p2yMZDBI9YyGDIZI+7OgqDI3kuRkeEzXzO96rV8kh99N9ia/GI3uwiJz7Ewn/SfWT5oKGHSJZeQ+WisyY7aUAM9Y/p3F+Jxyr3xhINfL2c+gGX2rxTb7yaehiSWMznB0UYXVuZYGRrmRMNJ2/UvdX+tQwULmfo25jBhhe0iTjwUiEPdwTzBetlVabFGCN6M+enJeQYIqsiVqli6MeC/9K0vO8Gq0zOoyKhR9xRLgIvlJVgAMN++MQrBvWdHWRxWEZ0X3X8+Yrjkx0/oIRgi5J9pylMAUnYdgzRdidAYrEsn6sbbkM1WurKf01eDn52GO+wz9Lp1R47ird9s0XoUiZOgSSz6rA3w3CVjAQPvN8osFj82Q7k9Dzhx7Uwnz1q5czuhaPwucYugpfe47k5jW+nMz/BiM3K8ex7slK2ugHESnW6MOWUsXpeKjvfBE8T/K40PkqxiZhJ+LOAb7UqKhC5be8jkNYBRKCN3m/EKw8pjbGl7YtJezA3GYXtUT1Y/R22O0fy1YIpuxUliG9HlhKahNVPdZs00v/doWFhHXMn/5cEf4ArEpfxEnufb/w1lQD67rSgyICtEnqroLxo5f4s4iB5s75wDjzwrN6bZXIxLi4nj3iN6JkV5LtGTpOhYVPbeHHHbInz67ch5jLi0ky/+YmO9Qw8BZf1DRWYt6JXq2Mimsi/lv5T41jI8/vcE7m2LnKSyYTHkuHr0DwK5njVFXZI8oKzOSK5U0KnZqRx9FO/8uSlWDZyDDS2uu7oHXqpvR0V4KXPO83aJ1z6ygo6FvaZUA+S1KX/jnhMO41TpEyQvHrlGp2fUCTkuqx/6DNR6kGisS0gD3yO3ldXF9ubkmC0+nevFUHEUV0ZFMVpnTiYol5vqWAHGE4bYGg8BcC60fVVbZHngwO6V4C7G5juaRmnOV0rsjD942y8enF2s2jIpk3PgyX1yhNa9QGzMSp7nzolY2pJ4UmUDVYJlaYl0xR7Ne62PrGYvkUdmX9O2dL087RTdAPHICD/5trfkOTIj5it7G8oOs80oHWUcEJPT7GN16BjzOrbrSOljWZcZXOOSdQreJPyOFp/hr6ES/Olu4d9vZCTOaMuqt07E9iAeuIlQ87GDu87k90gMWShrjSDxkk9iUzZKq2FUBHOAG7VpTXZD2y2nb2WCKgGKlULOfjCm5JSzTGh1EeE8t8vpifnEak/1eh0ZuekIvS4R7AXsq5m5HOKA5VY9kplPEC+L7C3gqUfaW2xR6/QUL1ztf8TRh3h3pdPhiBIE3udKkP8Y3mC7+feSzRqvZ5d5AoMELllfOK3l8/rUMRMdDYlnz11pKjmyiOesaEyy55gvIwc5PZ9Abfu0620Jbc8KcvrOH884PxUavelvzSj5CC1hCH5IUfK18CBmODDS5UTsFQqYeLhNoyI4YKRW6tEodYPTVyi+rBaeS67aqoDj7OYUnRdydv1I7q4nEUaONBsjibY3Lh1pVEwtLhs3IFgG9ewkd2lgL6jQ+tlLcRILIIBtfxc9oc3wjoiuNm2wrJnZFxTFNBNB6QwFFFhpmxXFzGFAvS2C1W3dL+DG/UVXxtQ5UJqKTSzp1he7iOGlKRtAvg4urPxLnO7f8BFmSRcLdbM97/xdFcjTeZiHG10RmxaSEX2vD/KzI19JXzCPHK6W7/qd7rbMzBnj4kqTz4CISk7xZma+7cGshAq40XGjYgIcSftXnE431TTr3IY3m1TSAqhBOdXSy4FBUH54X3X173ROX4mLs/O1eXwFqXHdh6RdL6Cyz4FPBwEmyNzmJ6B6IkUKu6KbQlx6ninDVZVLUl1sexAQu3E/rV9PuGrNYypSmEjJn3zGAc3xl2LPsbJ5UJIic8fLvFOVFIOobc59gSPeN38m+9pEaT+xShbeIgvL9KWwXNA6hcgQyU1obAFPZEIRT/shYYrDdjkngfh7hs87lmW2dLwvJUs8xB4c1E4PQL/ejeHvOXyF3jx8xKC93Twwe3XSK930is/70sOtsa5uRPlvdBflDXA3Wwo9Nwd4yinFjE8Ir9vAm1a10c51IH8JOs4Y0d7LgxQhpe0l9Q9hgTBxi4gORfCt/iXyMjcYdQBBKOCuOv9o1EFlcuW0A3cuDKObjfGjuF0GcWBJkA1SJzsn3XkJ/bRxDNOru3xVunYbecDQqJOi2XpHoEKEHGcn2RAk2F39ntst9qCzOryOVfGUYJigSXmVq2tEot8o3FN7/2/knunUnKw7UoI2sXBacT1PvfTqnV1oXUgfdCl2c+FKRuPTFQ2u/V1i0esrAXc2nD5i7hWS4sp+NbS59jUjSoBEP5gMIKLwrTAvuf1jQndTBV3FUPkW0BIQPp7uwZNnYySeovwKGxljTi7UB1wnjZ+He2kCiup6j/iKU9ypscpeI0wj6uBNDav2+Eaom57sYwE+Z7qrANM/gYgPlY6sCI+UHyyjaK3JsNBZ5bb2uIHLptqSRrpNXSda9Ja7FrsDdA6MWbkSlqBThVxBqXS1BOnkmsqF2yaf9/N3ybYM6ftpwgS6BCKqcT9QnHED9vuHIf2sXvoKO49aKgQZdz4rERKs+i3e2KLRGYPyRE/UgS3WUNWIM5O3CyccDk+ih89duqwG3/abCpdrBciEaor9MZsxVg+FBKZq3DyWueBxJdI3gvkXCj+f5KZwtR00J8dUSKG29C2JV3SsV9a7rqqegoV35KzqGB6JSgg1srdMRHMaSYSLsWzO58JQ6wao0sg/ffXwsjO6Rwz/gM3YATrqRijB9DKztpjP+P06p5S1Rg85mnoqmVrAXJiqjfe81F6NSGJX8TK4xlQR+qu1naae4WJuPkPcSIbLM8kH8mTAlLpK5tgY5v+mKzrdH/xf2l3sNLWjapp21GYXLiTu5JYSu1EKUTn/wUlc+Pv/pjWwDvvuwpF0gyjbRkaRZoV/2vFvDXdkPodf6hLpY13Qqx5LHUv0bkLU739sxaxFT6sRzGFZ2AtEeFxuiKXoRutXaAhbpXWAPEGc4TNraU4YBCqXt4G+lGlYCYxdk/qPdgwFgtr/gJsJniQ5aOfkCQ8l89AMcPgr4hEzKcEwdru/4Whw6IvJzBzEc40yXT09wyu0sAZibRHY4+p+Nm+c7jZ8BpXlOHizIIVT9QGqp9K7TddkYqWa5S4N9o7kiaFUuvyLM8uNdMxD0n+r29GPfnDTi96miT5GajZjxt1xLFC9fmcaTltDuov58d+8Bo8+7QSJLpom+fLYRd3BzhNOLMN1om8c4dp4F7dxVl1OyJLTxBRrgFfbYYdBQHQ5WWZCdMRzxvlOt+u13KJxoMvk67fnPOBoXcbFlaYuA0E9TgXTi6Z8CxnGH/8GmrXas9XPYh1+hFkLvVHOI9ph3VEUzPPzhbmHZb5FxxCWfid/fLC4iH20cgNFPd/kDlHGGYey3CWy37ilcs9M3R3JVQ/YE04zoNC0c1nIPRNamB35Hr8/Bwn8c3eMIRFNpncGxoSYgzSnsp567TQaUX9ne4fKmv88JBkuvCEgve/5i13D8UY7rp9jOiqry+WHaKdmXPFM9i8dqx8r7bdgYZmEnfZhV6L2ms7KJFZY/OSj77ZwgHNq1uSyZVWkaNRu+shn2zgOCD51lUFjQTqYoJP2Fv1dc5c98FWRx6FqChA+DwYO+5ddccULkeyLl3qJEs5EfXDi5VRt4dkJ89sMV4iccPgs+i/tq56eE5Z5QEBTPBrGW9icfgKw1vMmIEA9LPK3lpZDSCtXc2wby7rt8CnN7kz02HRjXRQgSI/N8uhvj7ZJ9+vrhE3GZX58A+gKVuFRsYKM5QX98w9gp1YeiPDmLmaATbaOQXlPyzrMUeFfsf37T+filKsRsPYDNuuYE+c/Ct4fBf+l9a9i11teFja2xQf3lTlB/CBhGrX5TWD2KctId/yuXLXZEy6Ot2NYHLRJ9mAPezfeS3lyQK+nWErIya6OohjpECB9lFkf4mltoR9lSvtHYU4DiR4G+ERChHdet+u4P+568VXAODSmIhzx31dXhTZZm/2eL2dXvjo6JEpa+suhWk2wRcDsnCoycIDw1Dv2WBTkgZI+bD2ePv0UWDsUy1SbVSlckkpwFF6pY+VBQgPWMNLIdGovReRFR9l2wAQdH2NVG6pyBnNtpybTgJBZirx+xrO8eAzQLG8PZFbLxP3xYJAqk5CIsma3Vj/4S59kbQJkn0vfyBxV1XYSF13i9QojMynChSgyxyfJl6u3vg7y/vk2XsqoSO5RJp14h/oqrhzfSlyJKvwZe6NPf3qXpinxQz8Rz/Qj3LrS1bowXI01ysVAyRSFe7Y15GQqJwgYeeSVRtFozwxM55WH9lidR1uaeDpIY9h/6rsza9vzR7f8umYpHnJnF+xDDsQxZpx+7yphqGL2i6R82EvuB7KHNxV6WeqXOBTkMVQ8k/sTHp5qMrx+g1qwaVRDMKTOhrdwVXSoVKI2gqlnFumzOFiLmkHGWVCkfa4J0J+0ADIgiBCBbtdD9ShlKWTytV+IQq/qDJZ0ArWZ8kLWeofnzUFYMdVXoWZo3xiavSAAScBA7t6tSrhIMXTaXXWQzLrwWQ2seHj6p3V2bKnEFH819YpqmyXuFfbn48wPXCB3jJpH6wuzu59TBiFMDZHJ5vPEFReIZOD3PcDaO5rgdVt8h0VE+9S2cZl8ZR5juRApRJvDAaTan6Tp8VUrldLyuATerOQac16grG0RhQLvumk9ShOJeNabz2zz3V1wrg8v5+fvBBVc26L9GkuhWZm3qv1paTKfrvPf9EK+OTcr8FhWJqH2MfEsrNRb3F7oh4gznMdScygN1UAI28tf88PfI6cHSOdPBR6Cee4gxvZpGqqs4OMrqOSRjxVQndtQKHmt6zZkVWQPzO+aSR1Ozn0s7WGboEaOJb/mx90tc58ox6afzBAch+msAzUN3enmKqjRuUF1EFG6+O5cH7ujB2qL8v7Xs2G67zl5UkrD07RjwVt5kjUhO3ESK//Hei8SfKqlzmjMajH/vi6QiHqEP3Wn/umTjoU3f3mDwkXh+xkWp44PFDqCEDDEqFQaiLJyS6qXIj+sSWveGkzzFbwtLNaVUNTXWjjnxGR+MpeHrdILLDbnea8QH4Kep85NvdSbF0AOGYI5dQB/0KuBgBy3v/Tp5UTXLqtJg0q3xGZOoer7PYrWZSONBCkopwWKRvue+ivvzjBL9VzCwpYl9616l+6vQR6+g/1bvhPmX6WRbHSUHGeiaeg2KrMGKr/H1+ZIpf95aP1tLEun4LmGVL5mlXe6a7TUj72F2meVlepMn20DrCcRf+XCliQtDOMX9K/KOKTaf8uyDWlVQOvwK5WT7odKkHLaQTl9ISUWKyAKJebG2hsZciXCP824bSSDmJlYuAlcdLHXbQBCfQiii3ilpbgLCbsiERCGyZ4DkoTAUcP0J2l3abHElO+pHLaX78KRpqFE1V8qjSUNC4y2PCCVuBrsQ0RDppYSP2BfdyXf26dO6Bl98gZSCTWrfah0qVBp0Tx5AU8Xwg4A4U/5QaceBX4vS/GCV1rNV879AcZI1EYmx74RHV+yAOXb0f+CTTRo6ku1d6Y0450IENGYB2Z6ZzfCkCYLj6QlqZbmz+Tzhc6Extdt12Rjc+4vvXLIZk61vne7JJpKRPT+MNOkHIQwnl36n40obvat3o3wfQApoR7eRoxb9TF/snfM+SK4OLC3hG2ACkT6xBfr1pUbxNGFfnt3KrHDLUT3aZvyawetPT00gGXzq8MZrHig3HoCeiHlwQGSC59zqoTRMy1ZB5ISrCKXhsji4T03YoqgTuBnxbzRfBQupuwJFO+8LEHB3eG0FK2ogNdwlMEDanp2ShtdlYYrLrfY/sDtVuHZSjewhszgSeC9Hv02Ka5ajwHk7PUKttasBgwuEY/MilfKNua0AvCaEWybX/QU6uE4yriWL9n4G3xGOzQfPgPpG2yEjWRBlKTeVSDiGvZdJHClW1i6mRd398lRhCqoVK7w6RhnTCMfczE0HgpWwhDVscGGbcbPwET8kry0yX+AQ/5ebCs4wjcOCbOxhxdTwcnoaaaQJaQshcTXLIVPFPEM051St2o=" />
</div>

<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="2173C2F0" />
	<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="KCMoq9SO70WpAONL3fs6/uFy9VA4M7oyB/lBGO6MZnYyXiNNP2tyW0NiyqqIb37P2sZlDFDJcpSuI4eXkYAVZ9sGqrFXbSxHf0iJOBQfRtU9+L1zhxwuCSVCCpM5eeCa64zfr0L4XXOoDLXdVj5fep2AI/DyKgreQVslJw==" />
</div>





<nav class="navbar navbar-default navbar-fixed-top" role="navigation">
    <div class="container-fluid">
    <!-- Brand and toggle get grouped for better mobile display -->
    <div class="navbar-header ">
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-collapse-1">
        <span class="sr-only">Toggle navigation</span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </button>

    <a id="HomeLink" class="navbar-brand" href="../../default.aspx"><img src="../../Images/Icons/otm6_new_logo_3px_border_150.png" alt="" /></a>
    </div>
        

    <!-- Collect the nav links, forms, and other content for toggling -->
    <div class="collapse navbar-collapse" id="navbar-collapse-1">



      <ul class="nav navbar-nav ">
        <li><a href="../../section/news">News</a></li>
        <li><a href="../../section/entertainment">Entertainment</a></li>
        <li><a href="../../section/travel">Travel</a></li>
        <li><a href="../../section/features">Features</a></li>
        <li class="dropdown">
          <a href="#" class="dropdown-toggle" data-toggle="dropdown">More <b class="caret"></b></a>
          <ul class="dropdown-menu">
            <li><a href="../../tags/marriage%20equality">Marriage Equality</a></li>
            <li><a href="../../tags/donald%20trump">Trump</a></li>
            <li><a href="../../tags/pride">LGBT Pride</a></li>
            <li><a href="../../tags/homophobia">Homophobia</a></li>
            <li><a href="../../tags/transphobia">Transphobia</a></li>
            <li><a href="../../tags/coronavirus">Coronavirus</a></li>
            <li class="divider"></li>
              <li><a href="https://www.facebook.com/ontopmag" target="_blank">Facebook</a></li>
              <li><a href="https://www.twitter.com/ontopmag" target="_blank">Twitter</a></li>
              <li><a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank">RSS</a></li>
            <li class="divider"></li>
            <li><a href="../../newsletter">Newsletter</a></li>
            <li><a href="../../privacy">Privacy policy</a></li>
              <li><a href="../../about">About us</a></li>
              <li><a href="../../contact">Contact us</a></li>
              <li><a href="../../advertise">Advertise</a></li>

          </ul>
        </li>
   
      </ul>

        
      <div class="navbar-form navbar-right" role="search">
          <div class="form-group">
 <input name="ctl00$txtSearch" type="text" value="Search" id="txtSearch" class="form-control navbar-input" title="Search by keyword" />
 </div><a id="lnkSearch" class="btn btn-default" href="javascript:__doPostBack(&#39;ctl00$lnkSearch&#39;,&#39;&#39;)"><i class="glyphicon glyphicon-search"></i></a>
 
     
 </div> 
           		        
    </div><!-- /.navbar-collapse -->

    </div><!-- /.container-fluid -->
</nav>
     
    




        <div class="container body-content">
            
 
<div class="row">
<ul class="latestDSK list-inline hidden-xs ">

    <li class="col-sm-2"><a href='/article/50649/Carl_Nassib_Says_Support_To_Coming_Out_Gay_Has_Been_Incredible'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/Carl_Nassib_august_2021.jpg')"></div></div></div></a><a href='/article/50649/Carl_Nassib_Says_Support_To_Coming_Out_Gay_Has_Been_Incredible'> <p class="type-small ptxxs mtn pr5">Carl Nassib Says Support To Coming Out Gay Has Been 'Incredible'                                    </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50647/Olympic_Boxer_Nesthy_Petecio_Dedicates_Silver_Medal_To_LGBTQ_Community'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/Nesthy_Petecio_silver_2020_olympics.jpg')"></div></div></div></a><a href='/article/50647/Olympic_Boxer_Nesthy_Petecio_Dedicates_Silver_Medal_To_LGBTQ_Community'> <p class="type-small ptxxs mtn pr5">Olympic Boxer Nesthy Petecio Dedicates Silver Medal To LGBTQ Community                              </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50646/Neil_Patrick_Harris_To_Play_Single_Gay_Man_In_Darren_Stars_Uncoupled'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/neil_patrick_harris_sept_2020.jpg')"></div></div></div></a><a href='/article/50646/Neil_Patrick_Harris_To_Play_Single_Gay_Man_In_Darren_Stars_Uncoupled'> <p class="type-small ptxxs mtn pr5">Neil Patrick Harris To Play Single Gay Man In Darren Star's 'Uncoupled'                             </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50645/Charleston_Becomes_First_West_Virginia_City_To_Ban_Ex_Gay_Therapy'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/charleston_west_virginia_downtown.jpg')"></div></div></div></a><a href='/article/50645/Charleston_Becomes_First_West_Virginia_City_To_Ban_Ex_Gay_Therapy'> <p class="type-small ptxxs mtn pr5">Charleston Becomes First West Virginia City To Ban 'Ex-Gay' Therapy                                 </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50644/HRC_Sues_Tennessee_Over_Transgender_Bathroom_Law'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/hrc_logo.jpg')"></div></div></div></a><a href='/article/50644/HRC_Sues_Tennessee_Over_Transgender_Bathroom_Law'> <p class="type-small ptxxs mtn pr5">HRC Sues Tennessee Over Transgender Bathroom Law                                                    </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50643/After_Gay_Slur_Controversy_Matt_Damon_Says_He_Stands_With_The_LGBTQ_Community'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/matt_damon_project_greenlight_2015.jpg')"></div></div></div></a><a href='/article/50643/After_Gay_Slur_Controversy_Matt_Damon_Says_He_Stands_With_The_LGBTQ_Community'> <p class="type-small ptxxs mtn pr5">After Gay Slur Controversy, Matt Damon Says He 'Stands With The LGBTQ+ Community'                   </p></a></li>

    </ul>
    <ul class="latestDSK list-inline hidden-sm hidden-md hidden-lg">


    <li class="col-xs-4"><a href='/article/50649/Carl_Nassib_Says_Support_To_Coming_Out_Gay_Has_Been_Incredible'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/Carl_Nassib_august_2021.jpg')"></div></div></div></a><a href='/article/50649/Carl_Nassib_Says_Support_To_Coming_Out_Gay_Has_Been_Incredible'><p class="type-small ptxxs mtn pr5">Carl Nassib Says Support To Coming Out Gay Has Been 'Incredible'                                    </p></a></li>

    
    <li class="col-xs-4"><a href='/article/50647/Olympic_Boxer_Nesthy_Petecio_Dedicates_Silver_Medal_To_LGBTQ_Community'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/Nesthy_Petecio_silver_2020_olympics.jpg')"></div></div></div></a><a href='/article/50647/Olympic_Boxer_Nesthy_Petecio_Dedicates_Silver_Medal_To_LGBTQ_Community'><p class="type-small ptxxs mtn pr5">Olympic Boxer Nesthy Petecio Dedicates Silver Medal To LGBTQ Community                              </p></a></li>

    
    <li class="col-xs-4"><a href='/article/50646/Neil_Patrick_Harris_To_Play_Single_Gay_Man_In_Darren_Stars_Uncoupled'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/neil_patrick_harris_sept_2020.jpg')"></div></div></div></a><a href='/article/50646/Neil_Patrick_Harris_To_Play_Single_Gay_Man_In_Darren_Stars_Uncoupled'><p class="type-small ptxxs mtn pr5">Neil Patrick Harris To Play Single Gay Man In Darren Star's 'Uncoupled'                             </p></a></li>

    
    </ul>
</div>




    <div class="row im-centered hidden-xs" style="margin:auto; height:90px; max-width:728px;"><div style="background-color:#fff; width:728px; height:90px;"><div><!-- web_leaderboard -->
<!-- BEGIN JS TAG - OnTopMag Master Bottom 728x90 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231475" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>




        <div class="row im-centered hidden-sm hidden-md hidden-lg" style="margin:auto; max-width:320px;"><div  style="background-color:#fff; width:320px; height:50px;"><div><!-- BEGIN JS TAG - OnTopMag Mobi Leaderboard 320x50 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1318027" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>

    <div class="row">
 
    <table cellspacing="0" id="MainContent_FormView1" style="border-collapse:collapse;">
	<tr>
		<td colspan="2">
        
        <div class="article-headline-wrapper">
        <h1><span id="MainContent_FormView1_Label1" class="headline">Billy Eichner Calls His Upcoming Film 'The Gay 'War Of The Roses' You've Been Waiting For'          </span></h1>

        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div style="margin-bottom:5px;" data-title='Billy Eichner Calls His Upcoming Film 'The Gay 'War Of The Roses' You've Been Waiting For'' class="addthis_sharing_toolbox"></div>
        
            <ul class="h5 list-inline container text-sizing-80" style="color:#a8a8a8; padding:0; list-style-type:none;">
                <li style="padding:0;">By </li>
                <li style="color: #545454; padding:0; text-transform: uppercase;">
                    
                       <span id="MainContent_FormView1_Label2">On Top Magazine Staff                             </span>       
                   </li>
                <li style="padding:0;"> |  
              <span id="MainContent_FormView1_Label3">August 09, 2021</span></li>
            </ul>

            </div>
        
           
   <div class="col-md-8">  


       <span id="MainContent_FormView1_Media"><img class='img-responsive col-xs-12' src='http://www.ontopmag.com/images/ArticleImages/Billy_Eichner_attitude_dec_2018.jpg'/></span>
        <span id="MainContent_FormView1_lblBody" class="articleBody">
<p>Out comedian Billy Eichner will star in
an upcoming Amazon comedy film about a gay male couple getting
divorced.</p>
<p>According to <i>Deadline</i>,
<i>Ex-Husbands</i> is an original story developed by Eichner and Paul
Rudnick (<i>Jeffrey</i>, <i>In&amp;Out</i>), who wrote the
screenplay. It will be produced by Eichner and Berlanti/Schechter
Films.</p>
<p>The film centers on Daniel and Connor,
the first gay couple to marry in NYC when it became legal in 2015,
turning them into LGBT celebrities. The men now are getting an epic
divorce that will eclipse their over-the-top wedding.</p>
<p>“The concept of a big, gay divorce
comedy has been kicking around in my head for years and I cannot
think of better collaborators than groundbreaking producers Greg
[Berlanti] and Sarah [Schechter], and a true icon whose work I have
craved and admired since I was a young gay boy lusting after show
business, the brilliant Paul Rudnick who really paved the way for me
and many others,” Eichner said. “And we now have the perfect
partners in Amazon, who have already shown enormous passion for this
project. This is a dream team. Now, LET’S GET DIVORCED!!!”</p>
<p>“It's the gay 'WAR OF THE ROSES'
you've been waiting for,” Eichner said on Twitter.</p>
<p>Eichner, who is best known for his
<i>Billy on the Street</i> series, will begin shooting <i>Bros</i>
for Universal Pictures in September. The film makes Eichner the first
openly gay man to write, star in, and produce a comedy for a major
Hollywood studio.</p>
<p>(Related: <a href="http://www.ontopmag.com/article/50419/Billy_Eichner_To_Write_Star_In_Gay_Romantic_Comedy_Bros" target="_blank">Billy
Eichner to write, star in first gay romantic comedy from a major
Hollywood studio.</a>)</p>
</span>

       <!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_recommended_horizontal hidden-md hidden-lg" ></div>
 <div class="fb-comments" data-width="100%" data-mobile="auto-detect"  data-version="v2.3" data-numposts="5"></div>
          </div>
            <div class="col-md-4 hidden-xs hidden-sm">


<div height: 250px; width: 300px; background-color: white;><!-- BEGIN JS TAG - OnTopMag ROS 300x250 < - DO NOT MODIFY -->


<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231478" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div>




<div style="margin-top:30px" class="fb-page" data-href="https://www.facebook.com/ontopmag" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ontopmag"><a href="https://www.facebook.com/ontopmag">On Top Magazine</a></blockquote></div></div>


<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div style="margin-top:30px;" class="addthis_recommended_vertical"></div>

<div style="height:600px; width:300px; background-color:white;"><!-- BEGIN JS TAG - OnTopMag ROS 300x600 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1307502" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div></div>

    </td>
	</tr>
</table>


 
        
  </div>
    <div id="fb-root"></div>
<script>(function (d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=239547596064955";
    fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
    <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ontopmag" async="async"></script>
    <link href="http://fonts.googleapis.com/css?family=Crimson+Text:700" rel="stylesheet" type="text/css" />

     
            <footer class="bs-docs-footer" role="contentinfo" >
                <div class="container">
                            <div class="text-center center-block">
           
   
                <a href="https://www.facebook.com/ontopmag" target="_blank"><i id="social" class="fa fa-facebook-square fa-3x"></i></a>
	            <a href="https://twitter.com/ontopmag" target="_blank"><i id="social" class="fa fa-twitter-square fa-3x"></i></a>
	            <a href="https://plus.google.com/ontopmag" target="_blank"><i id="social" class="fa fa-google-plus-square fa-3x"></i></a>
                <a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank"><i id="social" class="fa fa-rss-square fa-3x"></i></a>
	            <a href="../../contact" target="_blank"><i id="social" class="fa fa-envelope-square fa-3x"></i></a>
</div>
                       
                    <ul class="bs-docs-footer-links text-muted">

                        <li ><a href="../../newsletter">Newsletter</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../privacy">Privacy</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../about">About</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../advertise">Advertise</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../contact">Contact</a></li>
                       
                    </ul>
 <p>&copy; 2021 On Top Media</p>
                </div>
          
            
    
</footer>
        </div>
           
       
</form>
    

 
</body>

</html>

