
<!DOCTYPE html>

<html lang="en">
<head><meta charset="utf-8" /><meta name="robots" content="default, follow" /><meta name="googlebot" content="default, follow" /><meta name="language" content="english" /><meta property="fb:pages" content="495043790511" /><meta name="msvalidate.01" content="1CBFE669AE929C594B3B0E1BF4E454CE" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><title>
	First Look: Hulu Releases Trailer For Season Two Of &#39;Love, Victor&#39; | On Top Magazine | LGBT News & Entertainment
</title>

   

          
        
      <script type="text/javascript">
          window.onload = function () {
              var myDiv = document.getElementById("MainContent_FormView1_lblBody");
              var myThirdPar = myDiv.getElementsByTagName("p")[3];
              var newDiv = document.createElement("div");
              newDiv.className = "adInjector";
            
              var newImg = document.createElement("img");
              newImg.src = "http://www.tqlkg.com/image-7388032-11098646-1400274404000";
              newImg.height = "250";
              newImg.width = "300";
              newImg.alt = "2Xist Shop";
              
              var newLink = document.createElement("a");
              newLink.href = "http://www.anrdoezrs.net/click-7388032-11098646-1400274404000";
              newLink.appendChild(newImg);
              newDiv.appendChild(newLink);
              myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

              


              //var newGANad = document.createElement("SCRIPT");
              //newGANad.src = "http://tag.gayadnetwork.com/ttj?id=1231478";
              //newGANad.type = "text/javascript";
              //newDiv.appendChild(newGANad);
              //myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

          }
       


      </script>
      
    <link href="../../favicon.ico" rel="shortcut icon" type="image/x-icon" /><link rel="alternate" type="application/atom+xml" title="atom" href="http://feeds2.feedburner.com/ontopmagazineheadlines" /><link href="../../Content/bootstrap.min.css" rel="stylesheet" /><link href="../../Content/Site.min.css" rel="stylesheet" />
   <script defer src="https://use.fontawesome.com/65f232d7af.js"></script>
    <script type="text/javascript" src='/Scripts/jquery-2.1.4.min.js' ></script>
    <script src='/Scripts/bootstrap.min.js' ></script>
   
    

<script>(function (i, s, o, g, r, a, m) { i.GoogleAnalyticsObject = r; i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments) }, i[r].l = 1 * new Date(); a = s.createElement(o), m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; m.parentNode.insertBefore(a, m) })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga'); ga('create', 'UA-823485-1', 'ontopmag.com'); ga('require', 'displayfeatures')
    ga('send', 'pageview', {});</script>

<meta name="description" content="Streaming service Hulu has released the first trailer for its upcoming second season of Love, Victor" /><meta name="keywords" content="gay film, love victor, michael cimino" /><link rel="image_src" href="http://www.ontopmag.com/images/ArticleImages/love_victor.jpg" /><link rel="amphtml" href="http://www.ontopmag.com/article/50537/First_Look_Hulu_Releases_Trailer_For_Season_Two_Of_Love_Victor/amp" /><link rel="canonical" href="http://www.ontopmag.com/article/50537/First_Look_Hulu_Releases_Trailer_For_Season_Two_Of_Love_Victor" /><meta property="og:description" content="Streaming service Hulu has released the first trailer for its upcoming second season of Love, Victor" /><meta property="og:type" content="article" /><meta property="og:title" content="First Look: Hulu Releases Trailer For Season Two Of &#39;Love, Victor&#39;" /><meta property="og:url" content="http://www.ontopmag.com/article/50537/First_Look_Hulu_Releases_Trailer_For_Season_Two_Of_Love_Victor?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><meta property="og:image" content="http://www.ontopmag.com/images/ArticleImages/love_victor.jpg" /><meta property="og:site_name" content="On Top Magazine" /><meta property="fb:admins" content="495043790511" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@ontopmag" /><meta name="twitter:title" content="First Look: Hulu Releases Trailer For Season Two Of &#39;Love, Victor&#39;" /><meta name="twitter:description" content="Streaming service Hulu has released the first trailer for its upcoming second season of Love, Victor" /><meta name="twitter:image" content="http://www.ontopmag.com/images/ArticleImages/love_victor.jpg" /><meta name="twitter:url" content="http://www.ontopmag.com/article/50537/First_Look_Hulu_Releases_Trailer_For_Season_Two_Of_Love_Victor?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><script type = "application/ld+json">{ "@context":  "http://schema.org", "@type": "NewsArticle", "headline": "First Look: Hulu Releases Trailer For Season Two Of 'Love, Victor'", "datePublished": "5/21/2021 7:38:00 AM", "description": "Streaming service Hulu has released the first trailer for its upcoming second season of Love, Victor", "publisher": {"@type": "Organization", "name": "On Top Magazine", "logo": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/icons/OTM_logo_for_AMP.jpg", "width": 372, "height": 58}}, "image": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/ArticleImages/love_victor.jpg", "height": 400, "width": 600}}</script></head>
<body>

 

    <form method="post" action="./First_Look_Hulu_Releases_Trailer_For_Season_Two_Of_Love_Victor?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3a+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" id="ctl01">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
</div>

<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="2173C2F0" />
	<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="ttFI96OO3jER9xYUyT7HuXv9JRdxI1EvCoERtNdRMF4S4LmGf+vpaCcGWhhzqJEPzJy48xINwT+2Yu9I8DRh2gfSgDcExVQAM5jGZUcu/jBIlNXMtPMpqq8x/kpudFjv5lSu8hHMO4xpjS1bL2VxWXLJW71CXrobIJL/jg==" />
</div>





<nav class="navbar navbar-default navbar-fixed-top" role="navigation">
    <div class="container-fluid">
    <!-- Brand and toggle get grouped for better mobile display -->
    <div class="navbar-header ">
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-collapse-1">
        <span class="sr-only">Toggle navigation</span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </button>

    <a id="HomeLink" class="navbar-brand" href="../../default.aspx"><img src="../../Images/Icons/otm6_new_logo_3px_border_150.png" alt="" /></a>
    </div>
        

    <!-- Collect the nav links, forms, and other content for toggling -->
    <div class="collapse navbar-collapse" id="navbar-collapse-1">



      <ul class="nav navbar-nav ">
        <li><a href="../../section/news">News</a></li>
        <li><a href="../../section/entertainment">Entertainment</a></li>
        <li><a href="../../section/travel">Travel</a></li>
        <li><a href="../../section/features">Features</a></li>
        <li class="dropdown">
          <a href="#" class="dropdown-toggle" data-toggle="dropdown">More <b class="caret"></b></a>
          <ul class="dropdown-menu">
            <li><a href="../../tags/marriage%20equality">Marriage Equality</a></li>
            <li><a href="../../tags/donald%20trump">Trump</a></li>
            <li><a href="../../tags/pride">LGBT Pride</a></li>
            <li><a href="../../tags/homophobia">Homophobia</a></li>
            <li><a href="../../tags/transphobia">Transphobia</a></li>
            <li><a href="../../tags/coronavirus">Coronavirus</a></li>
            <li class="divider"></li>
              <li><a href="https://www.facebook.com/ontopmag" target="_blank">Facebook</a></li>
              <li><a href="https://www.twitter.com/ontopmag" target="_blank">Twitter</a></li>
              <li><a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank">RSS</a></li>
            <li class="divider"></li>
            <li><a href="../../newsletter">Newsletter</a></li>
            <li><a href="../../privacy">Privacy policy</a></li>
              <li><a href="../../about">About us</a></li>
              <li><a href="../../contact">Contact us</a></li>
              <li><a href="../../advertise">Advertise</a></li>

          </ul>
        </li>
   
      </ul>

        
      <div class="navbar-form navbar-right" role="search">
          <div class="form-group">
 <input name="ctl00$txtSearch" type="text" value="Search" id="txtSearch" class="form-control navbar-input" title="Search by keyword" />
 </div><a id="lnkSearch" class="btn btn-default" href="javascript:__doPostBack(&#39;ctl00$lnkSearch&#39;,&#39;&#39;)"><i class="glyphicon glyphicon-search"></i></a>
 
     
 </div> 
           		        
    </div><!-- /.navbar-collapse -->

    </div><!-- /.container-fluid -->
</nav>
     
    




        <div class="container body-content">
            
 
<div class="row">
<ul class="latestDSK list-inline hidden-xs ">

    <li class="col-sm-2"><a href='/article/50536/Sara_Ramirez_Joins_Sex_And_The_City_As_First_Ever_Non_Binary_Character'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/sara_ramirez_true_colors_oct_2016.jpg')"></div></div></div></a><a href='/article/50536/Sara_Ramirez_Joins_Sex_And_The_City_As_First_Ever_Non_Binary_Character'> <p class="type-small ptxxs mtn pr5">Sara Ramirez Joins 'Sex And The City' As First-Ever Non-Binary Character                            </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50535/Pose_Star_Billy_Porter_Reveals_Hes_HIV_Positive'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/billy_porter_thr_cover_june_2021.jpg')"></div></div></div></a><a href='/article/50535/Pose_Star_Billy_Porter_Reveals_Hes_HIV_Positive'> <p class="type-small ptxxs mtn pr5">'Pose' Star Billy Porter Reveals He's HIV-Positive                                                  </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50534/Demi_Lovato_Comes_Out_As_Non_Binary'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/demi_lovato_may_2021.jpg')"></div></div></div></a><a href='/article/50534/Demi_Lovato_Comes_Out_As_Non_Binary'> <p class="type-small ptxxs mtn pr5">Demi Lovato Comes Out As Non-Binary                                                                 </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50533/After_Gay_Couples_Sue_US_Reverses_On_Recognizing_Citizenship_Of_Children_Born_Abroad'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/derek_mize_jonathan_gregg_simone.jpg')"></div></div></div></a><a href='/article/50533/After_Gay_Couples_Sue_US_Reverses_On_Recognizing_Citizenship_Of_Children_Born_Abroad'> <p class="type-small ptxxs mtn pr5">After Gay Couples Sue, US Reverses On Recognizing Citizenship Of Children Born Abroad               </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50532/Billy_Porter_Calls_Pose_Series_Finale_Bittersweet'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/billy_porter_gma.jpg')"></div></div></div></a><a href='/article/50532/Billy_Porter_Calls_Pose_Series_Finale_Bittersweet'> <p class="type-small ptxxs mtn pr5">Billy Porter Calls 'Pose' Series Finale 'Bittersweet'                                               </p></a></li>

    
    <li class="col-sm-2"><a href='/article/50531/NCAA_Championships_To_Be_Held_In_States_With_Transgender_Sports_Bans'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/ncaa_logo_court.jpg')"></div></div></div></a><a href='/article/50531/NCAA_Championships_To_Be_Held_In_States_With_Transgender_Sports_Bans'> <p class="type-small ptxxs mtn pr5">NCAA Championships To Be Held In States With Transgender Sports Bans                                </p></a></li>

    </ul>
    <ul class="latestDSK list-inline hidden-sm hidden-md hidden-lg">


    <li class="col-xs-4"><a href='/article/50536/Sara_Ramirez_Joins_Sex_And_The_City_As_First_Ever_Non_Binary_Character'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/sara_ramirez_true_colors_oct_2016.jpg')"></div></div></div></a><a href='/article/50536/Sara_Ramirez_Joins_Sex_And_The_City_As_First_Ever_Non_Binary_Character'><p class="type-small ptxxs mtn pr5">Sara Ramirez Joins 'Sex And The City' As First-Ever Non-Binary Character                            </p></a></li>

    
    <li class="col-xs-4"><a href='/article/50535/Pose_Star_Billy_Porter_Reveals_Hes_HIV_Positive'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/billy_porter_thr_cover_june_2021.jpg')"></div></div></div></a><a href='/article/50535/Pose_Star_Billy_Porter_Reveals_Hes_HIV_Positive'><p class="type-small ptxxs mtn pr5">'Pose' Star Billy Porter Reveals He's HIV-Positive                                                  </p></a></li>

    
    <li class="col-xs-4"><a href='/article/50534/Demi_Lovato_Comes_Out_As_Non_Binary'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/demi_lovato_may_2021.jpg')"></div></div></div></a><a href='/article/50534/Demi_Lovato_Comes_Out_As_Non_Binary'><p class="type-small ptxxs mtn pr5">Demi Lovato Comes Out As Non-Binary                                                                 </p></a></li>

    
    </ul>
</div>




    <div class="row im-centered hidden-xs" style="margin:auto; height:90px; max-width:728px;"><div style="background-color:#fff; width:728px; height:90px;"><div><!-- web_leaderboard -->
<!-- BEGIN JS TAG - OnTopMag Master Bottom 728x90 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231475" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>




        <div class="row im-centered hidden-sm hidden-md hidden-lg" style="margin:auto; max-width:320px;"><div  style="background-color:#fff; width:320px; height:50px;"><div><!-- BEGIN JS TAG - OnTopMag Mobi Leaderboard 320x50 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1318027" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>

    <div class="row">
 
    <table cellspacing="0" id="MainContent_FormView1" style="border-collapse:collapse;">
	<tr>
		<td colspan="2">
        
        <div class="article-headline-wrapper">
        <h1><span id="MainContent_FormView1_Label1" class="headline">First Look: Hulu Releases Trailer For Season Two Of 'Love, Victor'                                  </span></h1>

        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div style="margin-bottom:5px;" data-title='First Look: Hulu Releases Trailer For Season Two Of 'Love, Victor'' class="addthis_sharing_toolbox"></div>
        
            <ul class="h5 list-inline container text-sizing-80" style="color:#a8a8a8; padding:0; list-style-type:none;">
                <li style="padding:0;">By </li>
                <li style="color: #545454; padding:0; text-transform: uppercase;">
                    
                       <span id="MainContent_FormView1_Label2">On Top Magazine Staff                             </span>       
                   </li>
                <li style="padding:0;"> |  
              <span id="MainContent_FormView1_Label3">May 21, 2021</span></li>
            </ul>

            </div>
        
           
   <div class="col-md-8">  


       <span id="MainContent_FormView1_Media"><iframe class='item-responsive col-xs-12' width='640' height='360' style='border:none; overflow:hidden;' src='http://www.youtube.com/embed/S7iyAHFoih8?wmode=transparent' frameborder='0' allowfullscreen></iframe></span>
        <span id="MainContent_FormView1_lblBody" class="articleBody">
<p>Streaming service Hulu has released the
first trailer for its upcoming second season of <i>Love, Victor</i>.</p>
<p>The gay teen rom-com returns for its
second season on June 11.</p>
<p><i>Love, Victor</i> is inspired by and
set in the same world as the 2018 gay coming-of-age film <i>Love,
Simon</i>.</p>
<p>The half-hour series centers on Victor
(played by Michael Cimino), a new student at Creekwood High School,
as he adjusts to a new city and struggles with his sexual
orientation.</p>
<p>In season two, Victor is out of the
closet as he enters his junior year at Creekwood High.</p>
<p>The trailer also shows Victor
navigating his first gay romance with Benji (George Sear) and the
fallout from breaking up with his ex-girlfriend Mia (Rachel Hilson).
Another storyline is Victor's family struggling with his coming out.</p>
<p>Rounding out the cast are Anthony
Turpel, Bebe Wood, Mason Gooding, Isabella Ferreira, Mateo Fernandez,
James Martinez, and Ana Ortiz.</p>
<p><i>Love, Victor</i> was originally
scheduled to air on Disney's streaming platform, Disney+, but was
moved to Hulu, which is controlled by Disney. Co-showrunner Brian
Tanen recently said that the move was a “gigantic win” for the
show.</p>
<p>“For me, it’s a gigantic win that
we are on Hulu moving forward. It opens our ability to tell more
adult stories,” <a href="https://tvline.com/2020/08/07/love-victor-renewed-season-2-hulu/" target="_blank">Tanen
told </a><a href="https://tvline.com/2020/08/07/love-victor-renewed-season-2-hulu/" target="_blank"><i>TVLine</i></a>.
“We’d love to tell sexier stories. That’s going to be so much
more exciting on a network like Hulu, which, since they’ve adopted
us, have been so supportive of the show and incredible partners.”</p>
</span>

       <!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_recommended_horizontal hidden-md hidden-lg" ></div>
 <div class="fb-comments" data-width="100%" data-mobile="auto-detect"  data-version="v2.3" data-numposts="5"></div>
          </div>
            <div class="col-md-4 hidden-xs hidden-sm">


<div height: 250px; width: 300px; background-color: white;><!-- BEGIN JS TAG - OnTopMag ROS 300x250 < - DO NOT MODIFY -->


<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231478" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div>




<div style="margin-top:30px" class="fb-page" data-href="https://www.facebook.com/ontopmag" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ontopmag"><a href="https://www.facebook.com/ontopmag">On Top Magazine</a></blockquote></div></div>


<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div style="margin-top:30px;" class="addthis_recommended_vertical"></div>

<div style="height:600px; width:300px; background-color:white;"><!-- BEGIN JS TAG - OnTopMag ROS 300x600 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1307502" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div></div>

    </td>
	</tr>
</table>


 
        
  </div>
    <div id="fb-root"></div>
<script>(function (d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=239547596064955";
    fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
    <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ontopmag" async="async"></script>
    <link href="http://fonts.googleapis.com/css?family=Crimson+Text:700" rel="stylesheet" type="text/css" />

     
            <footer class="bs-docs-footer" role="contentinfo" >
                <div class="container">
                            <div class="text-center center-block">
           
   
                <a href="https://www.facebook.com/ontopmag" target="_blank"><i id="social" class="fa fa-facebook-square fa-3x"></i></a>
	            <a href="https://twitter.com/ontopmag" target="_blank"><i id="social" class="fa fa-twitter-square fa-3x"></i></a>
	            <a href="https://plus.google.com/ontopmag" target="_blank"><i id="social" class="fa fa-google-plus-square fa-3x"></i></a>
                <a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank"><i id="social" class="fa fa-rss-square fa-3x"></i></a>
	            <a href="../../contact" target="_blank"><i id="social" class="fa fa-envelope-square fa-3x"></i></a>
</div>
                       
                    <ul class="bs-docs-footer-links text-muted">

                        <li ><a href="../../newsletter">Newsletter</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../privacy">Privacy</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../about">About</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../advertise">Advertise</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../contact">Contact</a></li>
                       
                    </ul>
 <p>&copy; 2021 On Top Media</p>
                </div>
          
            
    
</footer>
        </div>
           
       
</form>
    

 
</body>

</html>

