
<!DOCTYPE html>

<html lang="en">
<head><meta charset="utf-8" /><meta name="robots" content="default, follow" /><meta name="googlebot" content="default, follow" /><meta name="language" content="english" /><meta property="fb:pages" content="495043790511" /><meta name="msvalidate.01" content="1CBFE669AE929C594B3B0E1BF4E454CE" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><title>
	Florida Police Chief Suspended After Blaming Gay Cop&#39;s COVID-19 Death On His Sexuality | On Top Magazine | LGBT News & Entertainment
</title>

   

          
        
      <script type="text/javascript">
          window.onload = function () {
              var myDiv = document.getElementById("MainContent_FormView1_lblBody");
              var myThirdPar = myDiv.getElementsByTagName("p")[3];
              var newDiv = document.createElement("div");
              newDiv.className = "adInjector";
            
              var newImg = document.createElement("img");
              newImg.src = "http://www.tqlkg.com/image-7388032-11098646-1400274404000";
              newImg.height = "250";
              newImg.width = "300";
              newImg.alt = "2Xist Shop";
              
              var newLink = document.createElement("a");
              newLink.href = "http://www.anrdoezrs.net/click-7388032-11098646-1400274404000";
              newLink.appendChild(newImg);
              newDiv.appendChild(newLink);
              myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

              


              //var newGANad = document.createElement("SCRIPT");
              //newGANad.src = "http://tag.gayadnetwork.com/ttj?id=1231478";
              //newGANad.type = "text/javascript";
              //newDiv.appendChild(newGANad);
              //myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

          }
       


      </script>
      
    <link href="../../favicon.ico" rel="shortcut icon" type="image/x-icon" /><link rel="alternate" type="application/atom+xml" title="atom" href="http://feeds2.feedburner.com/ontopmagazineheadlines" /><link href="../../Content/bootstrap.min.css" rel="stylesheet" /><link href="../../Content/Site.min.css" rel="stylesheet" />
   <script defer src="https://use.fontawesome.com/65f232d7af.js"></script>
    <script type="text/javascript" src='/Scripts/jquery-2.1.4.min.js' ></script>
    <script src='/Scripts/bootstrap.min.js' ></script>
   
    

<script>(function (i, s, o, g, r, a, m) { i.GoogleAnalyticsObject = r; i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments) }, i[r].l = 1 * new Date(); a = s.createElement(o), m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; m.parentNode.insertBefore(a, m) })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga'); ga('create', 'UA-823485-1', 'ontopmag.com'); ga('require', 'displayfeatures')
    ga('send', 'pageview', {});</script>

<meta name="description" content="A South Florida police chief has been suspended after he blamed a gay cop&#39;s COVID-19 death on his &#39;homosexual&#39; lifestyle" /><meta name="keywords" content="homophobia, florida, shannon bennett, covid19, coronavirus" /><link rel="image_src" href="http://www.ontopmag.com/images/ArticleImages/shannon_bennett_2020.jpg" /><link rel="amphtml" href="http://www.ontopmag.com/article/47805/Florida_Police_Chief_Suspended_After_Blaming_Gay_Cops_COVID_19_Death_On_His_Sexuality/amp" /><link rel="canonical" href="http://www.ontopmag.com/article/47805/Florida_Police_Chief_Suspended_After_Blaming_Gay_Cops_COVID_19_Death_On_His_Sexuality" /><meta property="og:description" content="A South Florida police chief has been suspended after he blamed a gay cop&#39;s COVID-19 death on his &#39;homosexual&#39; lifestyle" /><meta property="og:type" content="article" /><meta property="og:title" content="Florida Police Chief Suspended After Blaming Gay Cop&#39;s COVID-19 Death On His Sexuality" /><meta property="og:url" content="http://www.ontopmag.com/article/47805/Florida_Police_Chief_Suspended_After_Blaming_Gay_Cops_COVID_19_Death_On_His_Sexuality?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><meta property="og:image" content="http://www.ontopmag.com/images/ArticleImages/shannon_bennett_2020.jpg" /><meta property="og:site_name" content="On Top Magazine" /><meta property="fb:admins" content="495043790511" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@ontopmag" /><meta name="twitter:title" content="Florida Police Chief Suspended After Blaming Gay Cop&#39;s COVID-19 Death On His Sexuality" /><meta name="twitter:description" content="A South Florida police chief has been suspended after he blamed a gay cop&#39;s COVID-19 death on his &#39;homosexual&#39; lifestyle" /><meta name="twitter:image" content="http://www.ontopmag.com/images/ArticleImages/shannon_bennett_2020.jpg" /><meta name="twitter:url" content="http://www.ontopmag.com/article/47805/Florida_Police_Chief_Suspended_After_Blaming_Gay_Cops_COVID_19_Death_On_His_Sexuality?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><script type = "application/ld+json">{ "@context":  "http://schema.org", "@type": "NewsArticle", "headline": "Florida Police Chief Suspended After Blaming Gay Cop's COVID-19 Death On His Sexuality", "datePublished": "4/12/2020 12:13:00 PM", "description": "A South Florida police chief has been suspended after he blamed a gay cop's COVID-19 death on his 'homosexual' lifestyle", "publisher": {"@type": "Organization", "name": "On Top Magazine", "logo": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/icons/OTM_logo_for_AMP.jpg", "width": 372, "height": 58}}, "image": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/ArticleImages/shannon_bennett_2020.jpg", "height": 400, "width": 600}}</script></head>
<body>

 

    <form method="post" action="./Florida_Police_Chief_Suspended_After_Blaming_Gay_Cops_COVID_19_Death_On_His_Sexuality?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3a+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" id="ctl01">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
</div>

<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="2173C2F0" />
	<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="/mXDe2TBVaKXtjRY8UEApwh7BUT6Uh83fidpPcvAmBp1DM2Jqff3JCOnDfIJdd3EHO4WRPfKQBVyHv7xcqXfAvFUjAI51E9QYuUf8hrIYa7ZSJSAMQ6R6JOjnhGV2F+/W5mN+n6ChRz22g5Pc0P58L2sKJyxO9Mqt6Z6Ag==" />
</div>





<nav class="navbar navbar-default navbar-fixed-top" role="navigation">
    <div class="container-fluid">
    <!-- Brand and toggle get grouped for better mobile display -->
    <div class="navbar-header ">
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-collapse-1">
        <span class="sr-only">Toggle navigation</span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </button>

    <a id="HomeLink" class="navbar-brand" href="../../default.aspx"><img src="../../Images/Icons/otm6_new_logo_3px_border_150.png" alt="" /></a>
    </div>
        

    <!-- Collect the nav links, forms, and other content for toggling -->
    <div class="collapse navbar-collapse" id="navbar-collapse-1">



      <ul class="nav navbar-nav ">
        <li><a href="../../section/news">News</a></li>
        <li><a href="../../section/entertainment">Entertainment</a></li>
        <li><a href="../../section/travel">Travel</a></li>
        <li><a href="../../section/features">Features</a></li>
        <li class="dropdown">
          <a href="#" class="dropdown-toggle" data-toggle="dropdown">More <b class="caret"></b></a>
          <ul class="dropdown-menu">
            <li><a href="../../tags/marriage%20equality">Marriage Equality</a></li>
            <li><a href="../../tags/donald%20trump">Trump</a></li>
            <li><a href="../../tags/pride">LGBT Pride</a></li>
            <li><a href="../../tags/homophobia">Homophobia</a></li>
            <li><a href="../../tags/transphobia">Transphobia</a></li>
            <li class="divider"></li>
              <li><a href="https://www.facebook.com/ontopmag" target="_blank">Facebook</a></li>
              <li><a href="https://www.twitter.com/ontopmag" target="_blank">Twitter</a></li>
              <li><a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank">RSS</a></li>
            <li class="divider"></li>
            <li><a href="../../newsletter">Newsletter</a></li>
            <li><a href="../../privacy">Privacy policy</a></li>
              <li><a href="../../about">About us</a></li>
              <li><a href="../../contact">Contact us</a></li>
              <li><a href="../../advertise">Advertise</a></li>

          </ul>
        </li>
   
      </ul>

        
      <div class="navbar-form navbar-right" role="search">
          <div class="form-group">
 <input name="ctl00$txtSearch" type="text" value="Search" id="txtSearch" class="form-control navbar-input" title="Search by keyword" />
 </div><a id="lnkSearch" class="btn btn-default" href="javascript:__doPostBack(&#39;ctl00$lnkSearch&#39;,&#39;&#39;)"><i class="glyphicon glyphicon-search"></i></a>
 
     
 </div> 
           		        
    </div><!-- /.navbar-collapse -->

    </div><!-- /.container-fluid -->
</nav>
     
    




        <div class="container body-content">
            
 
<div class="row">
<ul class="latestDSK list-inline hidden-xs ">

    <li class="col-sm-2"><a href='/article/47806/Virginia_Governor_Ralph_Northam_Signs_LGBT_Protections_Bill_Into_Law'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/ralph_northam_2018.jpg')"></div></div></div></a><a href='/article/47806/Virginia_Governor_Ralph_Northam_Signs_LGBT_Protections_Bill_Into_Law'> <p class="type-small ptxxs mtn pr5">Virginia Governor Ralph Northam Signs LGBT Protections Bill Into Law                                </p></a></li>

    
    <li class="col-sm-2"><a href='/article/47804/Pioneering_Lesbian_Activist_Phyllis_Lyon_Dies_At_95'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/phyllis_lyon_del_martin_wedding_2008.jpg')"></div></div></div></a><a href='/article/47804/Pioneering_Lesbian_Activist_Phyllis_Lyon_Dies_At_95'> <p class="type-small ptxxs mtn pr5">Pioneering Lesbian Activist Phyllis Lyon Dies At 95                                                 </p></a></li>

    
    <li class="col-sm-2"><a href='/article/47803/Dan_Levy_Sad_Pandemic_Canceled_Schitts_Creek_Live_Events_As_Series_Ends'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/Daniel_levy_jan_2019.jpg')"></div></div></div></a><a href='/article/47803/Dan_Levy_Sad_Pandemic_Canceled_Schitts_Creek_Live_Events_As_Series_Ends'> <p class="type-small ptxxs mtn pr5">Dan Levy 'Sad' Pandemic Canceled 'Schitt's Creek' Live Events As Series Ends                        </p></a></li>

    
    <li class="col-sm-2"><a href='/article/47802/The_Amazon_Trail_A_Giant'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/phyllis_lyon_del_martin.jpg')"></div></div></div></a><a href='/article/47802/The_Amazon_Trail_A_Giant'> <p class="type-small ptxxs mtn pr5">The Amazon Trail: A Giant                                                                           </p></a></li>

    
    <li class="col-sm-2"><a href='/article/47801/Virginia_Gov_Ralph_Northam_Signs_Non_Binary_Drivers_License_Bill'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/ralph_northam_2018.jpg')"></div></div></div></a><a href='/article/47801/Virginia_Gov_Ralph_Northam_Signs_Non_Binary_Drivers_License_Bill'> <p class="type-small ptxxs mtn pr5">Virginia Gov. Ralph Northam Signs Non-Binary Driver's License Bill                                  </p></a></li>

    
    <li class="col-sm-2"><a href='/article/47800/Modern_Family_Ends_With_Possible_Mitch_And_Cam_Spinoff'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/mitch_cam_wedding_modern_family.jpg')"></div></div></div></a><a href='/article/47800/Modern_Family_Ends_With_Possible_Mitch_And_Cam_Spinoff'> <p class="type-small ptxxs mtn pr5">'Modern Family' Ends With Possible Mitch And Cam Spinoff                                            </p></a></li>

    </ul>
    <ul class="latestDSK list-inline hidden-sm hidden-md hidden-lg">


    <li class="col-xs-4"><a href='/article/47806/Virginia_Governor_Ralph_Northam_Signs_LGBT_Protections_Bill_Into_Law'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/ralph_northam_2018.jpg')"></div></div></div></a><a href='/article/47806/Virginia_Governor_Ralph_Northam_Signs_LGBT_Protections_Bill_Into_Law'><p class="type-small ptxxs mtn pr5">Virginia Governor Ralph Northam Signs LGBT Protections Bill Into Law                                </p></a></li>

    
    <li class="col-xs-4"><a href='/article/47804/Pioneering_Lesbian_Activist_Phyllis_Lyon_Dies_At_95'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/phyllis_lyon_del_martin_wedding_2008.jpg')"></div></div></div></a><a href='/article/47804/Pioneering_Lesbian_Activist_Phyllis_Lyon_Dies_At_95'><p class="type-small ptxxs mtn pr5">Pioneering Lesbian Activist Phyllis Lyon Dies At 95                                                 </p></a></li>

    
    <li class="col-xs-4"><a href='/article/47803/Dan_Levy_Sad_Pandemic_Canceled_Schitts_Creek_Live_Events_As_Series_Ends'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/Daniel_levy_jan_2019.jpg')"></div></div></div></a><a href='/article/47803/Dan_Levy_Sad_Pandemic_Canceled_Schitts_Creek_Live_Events_As_Series_Ends'><p class="type-small ptxxs mtn pr5">Dan Levy 'Sad' Pandemic Canceled 'Schitt's Creek' Live Events As Series Ends                        </p></a></li>

    
    </ul>
</div>




    <div class="row im-centered hidden-xs" style="margin:auto; height:90px; max-width:728px;"><div style="background-color:#fff; width:728px; height:90px;"><div><!-- web_leaderboard -->
<!-- BEGIN JS TAG - OnTopMag Master Bottom 728x90 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231475" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>




        <div class="row im-centered hidden-sm hidden-md hidden-lg" style="margin:auto; max-width:320px;"><div  style="background-color:#fff; width:320px; height:50px;"><div><!-- BEGIN JS TAG - OnTopMag Mobi Leaderboard 320x50 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1318027" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>

    <div class="row">
 
    <table cellspacing="0" id="MainContent_FormView1" style="border-collapse:collapse;">
	<tr>
		<td colspan="2">
        
        <div class="article-headline-wrapper">
        <h1><span id="MainContent_FormView1_Label1" class="headline">Florida Police Chief Suspended After Blaming Gay Cop's COVID-19 Death On His Sexuality              </span></h1>

        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div style="margin-bottom:5px;" data-title='Florida Police Chief Suspended After Blaming Gay Cop's COVID-19 Death On His Sexuality' class="addthis_sharing_toolbox"></div>
        
            <ul class="h5 list-inline container text-sizing-80" style="color:#a8a8a8; padding:0; list-style-type:none;">
                <li style="padding:0;">By </li>
                <li style="color: #545454; padding:0; text-transform: uppercase;">
                    
                       <span id="MainContent_FormView1_Label2">Carlos Santoscoy                                  </span>       
                   </li>
                <li style="padding:0;"> |  
              <span id="MainContent_FormView1_Label3">April 12, 2020</span></li>
            </ul>

            </div>
        
           
   <div class="col-md-8">  


       <span id="MainContent_FormView1_Media"><img class='img-responsive col-xs-12' src='http://www.ontopmag.com/images/ArticleImages/shannon_bennett_2020.jpg'/></span>
        <span id="MainContent_FormView1_lblBody" class="articleBody">
<p>A South Florida police chief has been
suspended after he blamed a gay cop's COVID-19 death on his
“homosexual” lifestyle.</p>
<p>A complaint was filed against Chief
Dale Engle, the head of the Town of Davie's police department, after
he spoke with officers during a patrol briefing on April 7.</p>
<p>Deputy Shannon Bennett was a 12-year
veteran of the Broward Sheriff's Office and a school resource officer
at Deerfield Beach Elementary School.</p>
<p>Bennett died of complications from
COVID-19, the disease caused by the new coronavirus, 10 days after
testing positive for the virus. He was 39.</p>
<p>(Related: <a href="http://www.ontopmag.com/article/47799/Jonathan_Frey_Fiance_Of_Deputy_Shannon_Bennett_Says_Bennetts_Legacy_Will_Live_On" target="_blank">Jonathan
Frey, fiance of Deputy Shannon Bennett, says Bennett's “legacy will
live on.”</a>)</p>
<p>Engle attempted to minimize fears of
the virus by stating that Bennett's death was caused by his
“homosexual” lifestyle, the <a href="https://www.miamiherald.com/news/local/community/broward/article241947201.html" target="_blank"><i>Miami
Herald</i></a> reported.</p>
<p>Town administrators said that Engle had
been placed on administrative leave “pending further review of
allegations.”</p>
<p>The Florida State Lodge Fraternal Order
of Police Labor Council Committee criticized Engle's comments in a
letter to town administrators.</p>
<p>“He intimated that it was because of
the homosexual lifestyle that Deputy Bennett first contracted a
serious underlying disease which aggravated the Covid-19 virus and
led to his death,” the letter reads.</p>
<p>Michael Tucker, chief of staff for the
Fraternal Order of Police, said that officers had asked Engle
questions about their health insurance as it relates to COVID-19.</p>
<p>“Really utter shock that the chief
would attempt to minimize the risk to everyone and especially first
responders by trying to draw a link between what happened to Deputy
Bennett tragically and his sexual orientation,” Tucker said.</p>
<p>In an email to officers, Engle said
that his comments were “taken out of context” and that they were
“not intended to be derogatory” but informative.</p>
<p>As of Sunday, Florida was reporting
19,347 cases of COVID-19 with 452 deaths. While the state has been
testing more aggressively for the virus than some states, Republican
Governor Ron DeSantis waited until March 24 to order people to
shelter in place, 12 days after similar lockdowns were imposed on
residents in California, Illinois, and New York.</p>
</span>

       <!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_recommended_horizontal hidden-md hidden-lg" ></div>
 <div class="fb-comments" data-width="100%" data-mobile="auto-detect"  data-version="v2.3" data-numposts="5"></div>
          </div>
            <div class="col-md-4 hidden-xs hidden-sm">


<div height: 250px; width: 300px; background-color: white;><!-- BEGIN JS TAG - OnTopMag ROS 300x250 < - DO NOT MODIFY -->


<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231478" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div>




<div style="margin-top:30px" class="fb-page" data-href="https://www.facebook.com/ontopmag" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ontopmag"><a href="https://www.facebook.com/ontopmag">On Top Magazine</a></blockquote></div></div>


<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div style="margin-top:30px;" class="addthis_recommended_vertical"></div>

<div style="height:600px; width:300px; background-color:white;"><!-- BEGIN JS TAG - OnTopMag ROS 300x600 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1307502" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div></div>

    </td>
	</tr>
</table>


 
        
  </div>
    <div id="fb-root"></div>
<script>(function (d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=239547596064955";
    fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
    <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ontopmag" async="async"></script>
    <link href="http://fonts.googleapis.com/css?family=Crimson+Text:700" rel="stylesheet" type="text/css" />

     
            <footer class="bs-docs-footer" role="contentinfo" >
                <div class="container">
                            <div class="text-center center-block">
           
   
                <a href="https://www.facebook.com/ontopmag" target="_blank"><i id="social" class="fa fa-facebook-square fa-3x"></i></a>
	            <a href="https://twitter.com/ontopmag" target="_blank"><i id="social" class="fa fa-twitter-square fa-3x"></i></a>
	            <a href="https://plus.google.com/ontopmag" target="_blank"><i id="social" class="fa fa-google-plus-square fa-3x"></i></a>
                <a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank"><i id="social" class="fa fa-rss-square fa-3x"></i></a>
	            <a href="../../contact" target="_blank"><i id="social" class="fa fa-envelope-square fa-3x"></i></a>
</div>
                       
                    <ul class="bs-docs-footer-links text-muted">

                        <li ><a href="../../newsletter">Newsletter</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../privacy">Privacy</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../about">About</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../advertise">Advertise</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../contact">Contact</a></li>
                       
                    </ul>
 <p>&copy; 2020 On Top Media</p>
                </div>
          
            
    
</footer>
        </div>
           
       
</form>
    

 
</body>

</html>

