
<!DOCTYPE html>

<html lang="en">
<head><meta charset="utf-8" /><meta name="robots" content="default, follow" /><meta name="googlebot" content="default, follow" /><meta name="language" content="english" /><meta property="fb:pages" content="495043790511" /><meta name="msvalidate.01" content="1CBFE669AE929C594B3B0E1BF4E454CE" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><title>
	Terrence Howard: Jussie Smollett Could Not Have Conceived &#39;Something So Ugly&#39; | On Top Magazine | LGBT News & Entertainment
</title>

   

          
        
      <script type="text/javascript">
          window.onload = function () {
              var myDiv = document.getElementById("MainContent_FormView1_lblBody");
              var myThirdPar = myDiv.getElementsByTagName("p")[3];
              var newDiv = document.createElement("div");
              newDiv.className = "adInjector";
            
              var newImg = document.createElement("img");
              newImg.src = "http://www.tqlkg.com/image-7388032-11098646-1400274404000";
              newImg.height = "250";
              newImg.width = "300";
              newImg.alt = "2Xist Shop";
              
              var newLink = document.createElement("a");
              newLink.href = "http://www.anrdoezrs.net/click-7388032-11098646-1400274404000";
              newLink.appendChild(newImg);
              newDiv.appendChild(newLink);
              myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

              


              //var newGANad = document.createElement("SCRIPT");
              //newGANad.src = "http://tag.gayadnetwork.com/ttj?id=1231478";
              //newGANad.type = "text/javascript";
              //newDiv.appendChild(newGANad);
              //myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

          }
       


      </script>
      
    <link href="../../favicon.ico" rel="shortcut icon" type="image/x-icon" /><link rel="alternate" type="application/atom+xml" title="atom" href="http://feeds2.feedburner.com/ontopmagazineheadlines" /><link href="../../Content/bootstrap.min.css" rel="stylesheet" /><link href="../../Content/Site.min.css" rel="stylesheet" />
   <script defer src="https://use.fontawesome.com/65f232d7af.js"></script>
    <script type="text/javascript" src='/Scripts/jquery-2.1.4.min.js' ></script>
    <script src='/Scripts/bootstrap.min.js' ></script>
   
    

<script>(function (i, s, o, g, r, a, m) { i.GoogleAnalyticsObject = r; i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments) }, i[r].l = 1 * new Date(); a = s.createElement(o), m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; m.parentNode.insertBefore(a, m) })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga'); ga('create', 'UA-823485-1', 'ontopmag.com'); ga('require', 'displayfeatures')
    ga('send', 'pageview', {});</script>

<meta name="description" content="Terrence Howard has expressed support for fellow Empire cast member Jussie Smollett" /><meta name="keywords" content="gay celebrity, jussie smollett, terence howard, empire" /><link rel="image_src" href="http://www.ontopmag.com/images/ArticleImages/jussie_smollett_baby_flight.jpg" /><link rel="amphtml" href="http://www.ontopmag.com/article/46726/Terrence_Howard_Jussie_Smollett_Could_Not_Have_Conceived_Something_So_Ugly/amp" /><link rel="canonical" href="http://www.ontopmag.com/article/46726/Terrence_Howard_Jussie_Smollett_Could_Not_Have_Conceived_Something_So_Ugly" /><meta property="og:description" content="Terrence Howard has expressed support for fellow Empire cast member Jussie Smollett" /><meta property="og:type" content="article" /><meta property="og:title" content="Terrence Howard: Jussie Smollett Could Not Have Conceived &#39;Something So Ugly&#39;" /><meta property="og:url" content="http://www.ontopmag.com/article/46726/Terrence_Howard_Jussie_Smollett_Could_Not_Have_Conceived_Something_So_Ugly?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><meta property="og:image" content="http://www.ontopmag.com/images/ArticleImages/jussie_smollett_baby_flight.jpg" /><meta property="og:site_name" content="On Top Magazine" /><meta property="fb:admins" content="495043790511" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@ontopmag" /><meta name="twitter:title" content="Terrence Howard: Jussie Smollett Could Not Have Conceived &#39;Something So Ugly&#39;" /><meta name="twitter:description" content="Terrence Howard has expressed support for fellow Empire cast member Jussie Smollett" /><meta name="twitter:image" content="http://www.ontopmag.com/images/ArticleImages/jussie_smollett_baby_flight.jpg" /><meta name="twitter:url" content="http://www.ontopmag.com/article/46726/Terrence_Howard_Jussie_Smollett_Could_Not_Have_Conceived_Something_So_Ugly?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><script type = "application/ld+json">{ "@context":  "http://schema.org", "@type": "NewsArticle", "headline": "Terrence Howard: Jussie Smollett Could Not Have Conceived 'Something So Ugly'", "datePublished": "2/25/2019 9:29:00 AM", "description": "Terrence Howard has expressed support for fellow Empire cast member Jussie Smollett", "publisher": {"@type": "Organization", "name": "On Top Magazine", "logo": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/icons/OTM_logo_for_AMP.jpg", "width": 372, "height": 58}}, "image": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/ArticleImages/jussie_smollett_baby_flight.jpg", "height": 400, "width": 600}}</script></head>
<body>

 

    <form method="post" action="./Terrence_Howard_Jussie_Smollett_Could_Not_Have_Conceived_Something_So_Ugly?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3a+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" id="ctl01">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
</div>

<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="2173C2F0" />
	<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="42NfSQfb8B0D2cmVE/iOZ4mk7ppxQLa6Oh4xepSEPilEf/XCJn4ASjsU2duJW5EL6deoNK9MotxxcMwClFay1Rja3q7F/1GTGrY+QbGCZEJ+4gANqCw89QcABHIlMOd5g0u5TkQZny+uoPUrpxa9gA2Lb3KY8UPywHlKZA==" />
</div>





<nav class="navbar navbar-default navbar-fixed-top" role="navigation">
    <div class="container-fluid">
    <!-- Brand and toggle get grouped for better mobile display -->
    <div class="navbar-header ">
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-collapse-1">
        <span class="sr-only">Toggle navigation</span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </button>

    <a id="HomeLink" class="navbar-brand" href="../../default.aspx"><img src="../../Images/Icons/otm6_new_logo_3px_border_150.png" alt="" /></a>
    </div>
        

    <!-- Collect the nav links, forms, and other content for toggling -->
    <div class="collapse navbar-collapse" id="navbar-collapse-1">



      <ul class="nav navbar-nav ">
        <li><a href="../../section/news">News</a></li>
        <li><a href="../../section/entertainment">Entertainment</a></li>
        <li><a href="../../section/travel">Travel</a></li>
        <li><a href="../../section/features">Features</a></li>
        <li class="dropdown">
          <a href="#" class="dropdown-toggle" data-toggle="dropdown">More <b class="caret"></b></a>
          <ul class="dropdown-menu">
            <li><a href="../../tags/marriage%20equality">Marriage Equality</a></li>
            <li><a href="../../tags/donald%20trump">Trump</a></li>
            <li><a href="../../tags/pride">LGBT Pride</a></li>
            <li><a href="../../tags/homophobia">Homophobia</a></li>
            <li><a href="../../tags/transphobia">Transphobia</a></li>
            <li class="divider"></li>
              <li><a href="https://www.facebook.com/ontopmag" target="_blank">Facebook</a></li>
              <li><a href="https://www.twitter.com/ontopmag" target="_blank">Twitter</a></li>
              <li><a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank">RSS</a></li>
            <li class="divider"></li>
            <li><a href="../../newsletter">Newsletter</a></li>
            <li><a href="../../privacy">Privacy policy</a></li>
              <li><a href="../../about">About us</a></li>
              <li><a href="../../contact">Contact us</a></li>
              <li><a href="../../advertise">Advertise</a></li>

          </ul>
        </li>
   
      </ul>

        
      <div class="navbar-form navbar-right" role="search">
          <div class="form-group">
 <input name="ctl00$txtSearch" type="text" value="Search" id="txtSearch" class="form-control navbar-input" title="Search by keyword" />
 </div><a id="lnkSearch" class="btn btn-default" href="javascript:__doPostBack(&#39;ctl00$lnkSearch&#39;,&#39;&#39;)"><i class="glyphicon glyphicon-search"></i></a>
 
     
 </div> 
           		        
    </div><!-- /.navbar-collapse -->

    </div><!-- /.container-fluid -->
</nav>
     
    




        <div class="container body-content">
            
 
<div class="row">
<ul class="latestDSK list-inline hidden-xs ">

    <li class="col-sm-2"><a href='/article/46729/Colorado_House_Approves_Bill_That_Bans_Ex_Gay_Therapy'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/colorado_house_chamber.jpg')"></div></div></div></a><a href='/article/46729/Colorado_House_Approves_Bill_That_Bans_Ex_Gay_Therapy'> <p class="type-small ptxxs mtn pr5">Colorado House Approves Bill That Bans 'Ex-Gay' Therapy                                             </p></a></li>

    
    <li class="col-sm-2"><a href='/article/46728/Billy_Porter_Says_Oscars_Tuxedo_Dress_Was_About_Taking_Back_His_Power_As_A_Gay_Man'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/billy_porter_2019_oscars.jpg')"></div></div></div></a><a href='/article/46728/Billy_Porter_Says_Oscars_Tuxedo_Dress_Was_About_Taking_Back_His_Power_As_A_Gay_Man'> <p class="type-small ptxxs mtn pr5">Billy Porter Says Oscars Tuxedo Dress Was About Taking Back His Power As A Gay Man                  </p></a></li>

    
    <li class="col-sm-2"><a href='/article/46727/Queen_Adam_Lambert_Rock_Oscars_Opening_With_Freddie_Mercury_Tribute'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/adam_lambert_2019_oscars.jpg')"></div></div></div></a><a href='/article/46727/Queen_Adam_Lambert_Rock_Oscars_Opening_With_Freddie_Mercury_Tribute'> <p class="type-small ptxxs mtn pr5">Queen, Adam Lambert Rock Oscars Opening With Freddie Mercury Tribute                                </p></a></li>

    
    <li class="col-sm-2"><a href='/article/46725/Brian_Brown_Jussie_Smollett_Case_Shows_Gay_People_Weaponizing_LGBT_Civil_Rights'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/brian_brown_nom_meet_the_press_2015.jpg')"></div></div></div></a><a href='/article/46725/Brian_Brown_Jussie_Smollett_Case_Shows_Gay_People_Weaponizing_LGBT_Civil_Rights'> <p class="type-small ptxxs mtn pr5">Brian Brown: Jussie Smollett Case Shows Gay People 'Weaponizing' LGBT Civil Rights                  </p></a></li>

    
    <li class="col-sm-2"><a href='/article/46724/Ellen_Page_Says_She_Was_Pressured_Not_To_Come_Out_Gay'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/ellen_page_porter_feb_2019.jpg')"></div></div></div></a><a href='/article/46724/Ellen_Page_Says_She_Was_Pressured_Not_To_Come_Out_Gay'> <p class="type-small ptxxs mtn pr5">Ellen Page Says She Was Pressured Not To Come Out Gay                                               </p></a></li>

    
    <li class="col-sm-2"><a href='/article/46723/Jussie_Smollett_Dropped_From_Remainder_Of_Empire_Season'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/jussie_smollett_music_shirt.jpg')"></div></div></div></a><a href='/article/46723/Jussie_Smollett_Dropped_From_Remainder_Of_Empire_Season'> <p class="type-small ptxxs mtn pr5">Jussie Smollett Dropped From Remainder Of 'Empire' Season                                           </p></a></li>

    </ul>
    <ul class="latestDSK list-inline hidden-sm hidden-md hidden-lg">


    <li class="col-xs-4"><a href='/article/46729/Colorado_House_Approves_Bill_That_Bans_Ex_Gay_Therapy'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/colorado_house_chamber.jpg')"></div></div></div></a><a href='/article/46729/Colorado_House_Approves_Bill_That_Bans_Ex_Gay_Therapy'><p class="type-small ptxxs mtn pr5">Colorado House Approves Bill That Bans 'Ex-Gay' Therapy                                             </p></a></li>

    
    <li class="col-xs-4"><a href='/article/46728/Billy_Porter_Says_Oscars_Tuxedo_Dress_Was_About_Taking_Back_His_Power_As_A_Gay_Man'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/billy_porter_2019_oscars.jpg')"></div></div></div></a><a href='/article/46728/Billy_Porter_Says_Oscars_Tuxedo_Dress_Was_About_Taking_Back_His_Power_As_A_Gay_Man'><p class="type-small ptxxs mtn pr5">Billy Porter Says Oscars Tuxedo Dress Was About Taking Back His Power As A Gay Man                  </p></a></li>

    
    <li class="col-xs-4"><a href='/article/46727/Queen_Adam_Lambert_Rock_Oscars_Opening_With_Freddie_Mercury_Tribute'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/adam_lambert_2019_oscars.jpg')"></div></div></div></a><a href='/article/46727/Queen_Adam_Lambert_Rock_Oscars_Opening_With_Freddie_Mercury_Tribute'><p class="type-small ptxxs mtn pr5">Queen, Adam Lambert Rock Oscars Opening With Freddie Mercury Tribute                                </p></a></li>

    
    </ul>
</div>




    <div class="row im-centered hidden-xs" style="margin:auto; height:90px; max-width:728px;"><div style="background-color:#fff; width:728px; height:90px;"><div><!-- web_leaderboard -->
<!-- BEGIN JS TAG - OnTopMag Master Bottom 728x90 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231475" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>




        <div class="row im-centered hidden-sm hidden-md hidden-lg" style="margin:auto; max-width:320px;"><div  style="background-color:#fff; width:320px; height:50px;"><div><!-- BEGIN JS TAG - OnTopMag Mobi Leaderboard 320x50 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1318027" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>

    <div class="row">
 
    <table cellspacing="0" id="MainContent_FormView1" style="border-collapse:collapse;">
	<tr>
		<td colspan="2">
        
        <div class="article-headline-wrapper">
        <h1><span id="MainContent_FormView1_Label1" class="headline">Terrence Howard: Jussie Smollett Could Not Have Conceived 'Something So Ugly'                       </span></h1>

        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div style="margin-bottom:5px;" data-title='Terrence Howard: Jussie Smollett Could Not Have Conceived 'Something So Ugly'' class="addthis_sharing_toolbox"></div>
        
            <ul class="h5 list-inline container text-sizing-80" style="color:#a8a8a8; padding:0; list-style-type:none;">
                <li style="padding:0;">By </li>
                <li style="color: #545454; padding:0; text-transform: uppercase;">
                    
                       <span id="MainContent_FormView1_Label2">On Top Magazine Staff                             </span>       
                   </li>
                <li style="padding:0;"> |  
              <span id="MainContent_FormView1_Label3">February 25, 2019</span></li>
            </ul>

            </div>
        
           
   <div class="col-md-8">  


       <span id="MainContent_FormView1_Media"><img class='img-responsive col-xs-12' src='http://www.ontopmag.com/images/ArticleImages/jussie_smollett_baby_flight.jpg'/></span>
        <span id="MainContent_FormView1_lblBody" class="articleBody">
<p>Terrence Howard has expressed support
for fellow <i>Empire</i> cast member Jussie Smollett.</p>
<p>Howard plays the father of Smollett's
openly gay character on the Fox drama.</p>
<p>Howard on Saturday posted a video on
Instagram of Smollett holding and tickling a baby.  “All your lil
homies got you,” he captioned the video.  “We love the hell outta
you.”</p>
<p>On Thursday, Smollett, who is black and
gay, was arrested in connection with filing a false police report
claiming he was the victim of a racist and homophobic attack that
allegedly took place last month in Chicago.  Police believe Smollett
orchestrated his own attack because he was “dissatisfied with his
salary” on <i>Empire</i>.  Smollett has denied the allegations.</p>
<p>The following day, producers announced
that they have cut Smollett from the final two episodes of the show's
fifth season.</p>
<p>Smollett, who is on $100,000 bail,
reportedly visited the set of <i>Empire</i> on Thursday.</p>
<p>Howard responded to a user who
criticized his Instagram post.</p>
<p>“Sorry you feel that way,” Howard
wrote, “but that’s the only Jussie that I know. The Jussie that I
know could never even conceive of something so unconscious and ugly.
His innocence or judgment is not for any of us to decide. Stay in
your lane and my lane is empathy and love and compassion for someone
that I’ve called my son for 5 years. It’s God’s job to judge
and it is ours to love and hope, especially for those that we claim
to have loved. There’s nothing more harmful than a fake friend!
Real talk.”</p>
</span>

       <!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_recommended_horizontal hidden-md hidden-lg" ></div>
 <div class="fb-comments" data-width="100%" data-mobile="auto-detect"  data-version="v2.3" data-numposts="5"></div>
          </div>
            <div class="col-md-4 hidden-xs hidden-sm">


<div height: 250px; width: 300px; background-color: white;><!-- BEGIN JS TAG - OnTopMag ROS 300x250 < - DO NOT MODIFY -->


<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231478" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div>




<div style="margin-top:30px" class="fb-page" data-href="https://www.facebook.com/ontopmag" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ontopmag"><a href="https://www.facebook.com/ontopmag">On Top Magazine</a></blockquote></div></div>


<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div style="margin-top:30px;" class="addthis_recommended_vertical"></div>

<div style="height:600px; width:300px; background-color:white;"><!-- BEGIN JS TAG - OnTopMag ROS 300x600 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1307502" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div></div>

    </td>
	</tr>
</table>


 
        
  </div>
    <div id="fb-root"></div>
<script>(function (d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=239547596064955";
    fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
    <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ontopmag" async="async"></script>
    <link href="http://fonts.googleapis.com/css?family=Crimson+Text:700" rel="stylesheet" type="text/css" />

     
            <footer class="bs-docs-footer" role="contentinfo" >
                <div class="container">
                            <div class="text-center center-block">
           
   
                <a href="https://www.facebook.com/ontopmag" target="_blank"><i id="social" class="fa fa-facebook-square fa-3x"></i></a>
	            <a href="https://twitter.com/ontopmag" target="_blank"><i id="social" class="fa fa-twitter-square fa-3x"></i></a>
	            <a href="https://plus.google.com/ontopmag" target="_blank"><i id="social" class="fa fa-google-plus-square fa-3x"></i></a>
                <a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank"><i id="social" class="fa fa-rss-square fa-3x"></i></a>
	            <a href="../../contact" target="_blank"><i id="social" class="fa fa-envelope-square fa-3x"></i></a>
</div>
                       
                    <ul class="bs-docs-footer-links text-muted">

                        <li ><a href="../../newsletter">Newsletter</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../privacy">Privacy</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../about">About</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../advertise">Advertise</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../contact">Contact</a></li>
                       
                    </ul>
 <p>&copy; 2019 On Top Media</p>
                </div>
          
            
    
</footer>
        </div>
           
       
</form>
    

 
</body>

</html>

