
<!DOCTYPE html>

<html lang="en">
<head><meta charset="utf-8" /><meta name="robots" content="default, follow" /><meta name="googlebot" content="default, follow" /><meta name="language" content="english" /><meta property="fb:pages" content="495043790511" /><meta name="msvalidate.01" content="1CBFE669AE929C594B3B0E1BF4E454CE" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><title>
	Hayley Kiyoko Joins HRC&#39;s Equality Rocks Campaign | On Top Magazine | LGBT News & Entertainment
</title>

   

          
        
      <script type="text/javascript">
          window.onload = function () {
              var myDiv = document.getElementById("MainContent_FormView1_lblBody");
              var myThirdPar = myDiv.getElementsByTagName("p")[3];
              var newDiv = document.createElement("div");
              newDiv.className = "adInjector";
            
              var newImg = document.createElement("img");
              newImg.src = "http://www.tqlkg.com/image-7388032-11098646-1400274404000";
              newImg.height = "250";
              newImg.width = "300";
              newImg.alt = "2Xist Shop";
              
              var newLink = document.createElement("a");
              newLink.href = "http://www.anrdoezrs.net/click-7388032-11098646-1400274404000";
              newLink.appendChild(newImg);
              newDiv.appendChild(newLink);
              myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

              


              //var newGANad = document.createElement("SCRIPT");
              //newGANad.src = "http://tag.gayadnetwork.com/ttj?id=1231478";
              //newGANad.type = "text/javascript";
              //newDiv.appendChild(newGANad);
              //myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

          }
       


      </script>
      
    <link href="../../favicon.ico" rel="shortcut icon" type="image/x-icon" /><link rel="alternate" type="application/atom+xml" title="atom" href="http://feeds2.feedburner.com/ontopmagazineheadlines" /><link href="../../Content/bootstrap.min.css" rel="stylesheet" /><link href="../../Content/Site.min.css" rel="stylesheet" />
   <script defer src="https://use.fontawesome.com/65f232d7af.js"></script>
    <script type="text/javascript" src='/Scripts/jquery-2.1.4.min.js' ></script>
    <script src='/Scripts/bootstrap.min.js' ></script>
   
    

<script>(function (i, s, o, g, r, a, m) { i.GoogleAnalyticsObject = r; i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments) }, i[r].l = 1 * new Date(); a = s.createElement(o), m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; m.parentNode.insertBefore(a, m) })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga'); ga('create', 'UA-823485-1', 'ontopmag.com'); ga('require', 'displayfeatures')
    ga('send', 'pageview', {});</script>

<meta name="description" content="Singer-songwriter Hayley Kiyoko is the latest artist to join the Human Rights Campaign&#39;s (HRC) Equality Rocks campaign" /><meta name="keywords" content="lgbt rights, hrc, hayley kiyoko" /><link rel="image_src" href="http://www.ontopmag.com/images/ArticleImages/Hayley_Kiyoko_HRC_2018.jpg" /><link rel="amphtml" href="http://www.ontopmag.com/article/44915/Hayley_Kiyoko_Joins_HRCs_Equality_Rocks_Campaign/amp" /><link rel="canonical" href="http://www.ontopmag.com/article/44915/Hayley_Kiyoko_Joins_HRCs_Equality_Rocks_Campaign" /><meta property="og:description" content="Singer-songwriter Hayley Kiyoko is the latest artist to join the Human Rights Campaign&#39;s (HRC) Equality Rocks campaign" /><meta property="og:type" content="article" /><meta property="og:title" content="Hayley Kiyoko Joins HRC&#39;s Equality Rocks Campaign" /><meta property="og:url" content="http://www.ontopmag.com/article/44915/Hayley_Kiyoko_Joins_HRCs_Equality_Rocks_Campaign?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><meta property="og:image" content="http://www.ontopmag.com/images/ArticleImages/Hayley_Kiyoko_HRC_2018.jpg" /><meta property="og:site_name" content="On Top Magazine" /><meta property="fb:admins" content="495043790511" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@ontopmag" /><meta name="twitter:title" content="Hayley Kiyoko Joins HRC&#39;s Equality Rocks Campaign" /><meta name="twitter:description" content="Singer-songwriter Hayley Kiyoko is the latest artist to join the Human Rights Campaign&#39;s (HRC) Equality Rocks campaign" /><meta name="twitter:image" content="http://www.ontopmag.com/images/ArticleImages/Hayley_Kiyoko_HRC_2018.jpg" /><meta name="twitter:url" content="http://www.ontopmag.com/article/44915/Hayley_Kiyoko_Joins_HRCs_Equality_Rocks_Campaign?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><script type = "application/ld+json">{ "@context":  "http://schema.org", "@type": "NewsArticle", "headline": "Hayley Kiyoko Joins HRC's Equality Rocks Campaign", "datePublished": "7/7/2018 1:04:00 PM", "description": "Singer-songwriter Hayley Kiyoko is the latest artist to join the Human Rights Campaign's (HRC) Equality Rocks campaign", "publisher": {"@type": "Organization", "name": "On Top Magazine", "logo": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/icons/OTM_logo_for_AMP.jpg", "width": 372, "height": 58}}, "image": {"@type": "ImageObject", "url": "http://www.ontopmag.com/images/ArticleImages/Hayley_Kiyoko_HRC_2018.jpg", "height": 400, "width": 600}}</script></head>
<body>

 

    <form method="post" action="./Hayley_Kiyoko_Joins_HRCs_Equality_Rocks_Campaign?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3a+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" id="ctl01">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
</div>

<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="2173C2F0" />
	<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="zV2k7QjX0r/E2aAm/GkawYUS/HtYzbEdh3vqsPvHFxAVsCKtv++kJrJnSSQtMhFU4UCXWmsreK+0LJpRKsh5qT1IuvQNUkoUQ0qJBRoPK6e8kXN+0p8Et6/eKAjyM2IgkS0ZVJMUojBz3sJoVQWf/Ri3/Wm87OZmRj8mFQ==" />
</div>





<nav class="navbar navbar-default navbar-fixed-top" role="navigation">
    <div class="container-fluid">
    <!-- Brand and toggle get grouped for better mobile display -->
    <div class="navbar-header ">
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-collapse-1">
        <span class="sr-only">Toggle navigation</span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </button>

    <a id="HomeLink" class="navbar-brand" href="../../default.aspx"><img src="../../Images/Icons/otm6_new_logo_3px_border_150.png" alt="" /></a>
    </div>
        

    <!-- Collect the nav links, forms, and other content for toggling -->
    <div class="collapse navbar-collapse" id="navbar-collapse-1">



      <ul class="nav navbar-nav ">
        <li><a href="../../section/news">News</a></li>
        <li><a href="../../section/entertainment">Entertainment</a></li>
        <li><a href="../../section/travel">Travel</a></li>
        <li><a href="../../section/features">Features</a></li>
        <li class="dropdown">
          <a href="#" class="dropdown-toggle" data-toggle="dropdown">More <b class="caret"></b></a>
          <ul class="dropdown-menu">
            <li><a href="../../tags/marriage%20equality">Marriage Equality</a></li>
            <li><a href="../../tags/donald%20trump">Trump</a></li>
            <li><a href="../../tags/pride">LGBT Pride</a></li>
            <li><a href="../../tags/homophobia">Homophobia</a></li>
            <li><a href="../../tags/transphobia">Transphobia</a></li>
            <li class="divider"></li>
              <li><a href="https://www.facebook.com/ontopmag" target="_blank">Facebook</a></li>
              <li><a href="https://www.twitter.com/ontopmag" target="_blank">Twitter</a></li>
              <li><a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank">RSS</a></li>
            <li class="divider"></li>
            <li><a href="../../newsletter">Newsletter</a></li>
            <li><a href="../../privacy">Privacy policy</a></li>
              <li><a href="../../about">About us</a></li>
              <li><a href="../../contact">Contact us</a></li>
              <li><a href="../../advertise">Advertise</a></li>

          </ul>
        </li>
   
      </ul>

        
      <div class="navbar-form navbar-right" role="search">
          <div class="form-group">
 <input name="ctl00$txtSearch" type="text" value="Search" id="txtSearch" class="form-control navbar-input" title="Search by keyword" />
 </div><a id="lnkSearch" class="btn btn-default" href="javascript:__doPostBack(&#39;ctl00$lnkSearch&#39;,&#39;&#39;)"><i class="glyphicon glyphicon-search"></i></a>
 
     
 </div> 
           		        
    </div><!-- /.navbar-collapse -->

    </div><!-- /.container-fluid -->
</nav>
     
    




        <div class="container body-content">
            
 
<div class="row">
<ul class="latestDSK list-inline hidden-xs ">

    <li class="col-sm-2"><a href='/article/44916/Maine_Gov_Paul_LePage_Vetoes_Bill_Banning_Ex_Gay_Therapy'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/paul_lepage_2011.jpg')"></div></div></div></a><a href='/article/44916/Maine_Gov_Paul_LePage_Vetoes_Bill_Banning_Ex_Gay_Therapy'> <p class="type-small ptxxs mtn pr5">Maine Gov. Paul LePage Vetoes Bill Banning 'Ex-Gay' Therapy                                         </p></a></li>

    
    <li class="col-sm-2"><a href='/article/44914/Panic_At_The_Discos_Brendon_Urie_Comes_Out_Pansexual_Definitely_Attracted_To_Men'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/brendon_urie_zach_sang_march_2016.jpg')"></div></div></div></a><a href='/article/44914/Panic_At_The_Discos_Brendon_Urie_Comes_Out_Pansexual_Definitely_Attracted_To_Men'> <p class="type-small ptxxs mtn pr5">Panic! At The Disco's Brendon Urie Comes Out Pansexual; 'Definitely' Attracted To Men               </p></a></li>

    
    <li class="col-sm-2"><a href='/article/44913/Queer_Eyes_Antoni_Porowskis_Food_Advice_For_A_Breakup_Put_Them_In_A_Food_Coma'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/antoni_queer_eye_all_things.jpg')"></div></div></div></a><a href='/article/44913/Queer_Eyes_Antoni_Porowskis_Food_Advice_For_A_Breakup_Put_Them_In_A_Food_Coma'> <p class="type-small ptxxs mtn pr5">Queer Eye's Antoni Porowski's Food Advice For A Breakup: Put Them In A Food Coma                    </p></a></li>

    
    <li class="col-sm-2"><a href='/article/44912/Homophobic_Mayor_Resigns_After_Drag_Queen_Calls_Him_Out'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/tess_tickle_uk.jpg')"></div></div></div></a><a href='/article/44912/Homophobic_Mayor_Resigns_After_Drag_Queen_Calls_Him_Out'> <p class="type-small ptxxs mtn pr5">Homophobic Mayor Resigns After Drag Queen Calls Him Out                                             </p></a></li>

    
    <li class="col-sm-2"><a href='/article/44911/Collin_Martin_Gets_Standing_Ovation_At_First_Game_After_Coming_Out_Gay'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/collin_martin_standing_ovation_july_2018.jpg')"></div></div></div></a><a href='/article/44911/Collin_Martin_Gets_Standing_Ovation_At_First_Game_After_Coming_Out_Gay'> <p class="type-small ptxxs mtn pr5">Collin Martin Gets Standing Ovation At First Game After Coming Out Gay                              </p></a></li>

    
    <li class="col-sm-2"><a href='/article/44910/Kevin_Spacey_Faces_3_New_Allegations_Of_Sexual_Misconduct'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/kevin_spacey_ap_file.jpg')"></div></div></div></a><a href='/article/44910/Kevin_Spacey_Faces_3_New_Allegations_Of_Sexual_Misconduct'> <p class="type-small ptxxs mtn pr5">Kevin Spacey Faces 3 New Allegations Of Sexual Misconduct                                           </p></a></li>

    </ul>
    <ul class="latestDSK list-inline hidden-sm hidden-md hidden-lg">


    <li class="col-xs-4"><a href='/article/44916/Maine_Gov_Paul_LePage_Vetoes_Bill_Banning_Ex_Gay_Therapy'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/paul_lepage_2011.jpg')"></div></div></div></a><a href='/article/44916/Maine_Gov_Paul_LePage_Vetoes_Bill_Banning_Ex_Gay_Therapy'><p class="type-small ptxxs mtn pr5">Maine Gov. Paul LePage Vetoes Bill Banning 'Ex-Gay' Therapy                                         </p></a></li>

    
    <li class="col-xs-4"><a href='/article/44914/Panic_At_The_Discos_Brendon_Urie_Comes_Out_Pansexual_Definitely_Attracted_To_Men'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/brendon_urie_zach_sang_march_2016.jpg')"></div></div></div></a><a href='/article/44914/Panic_At_The_Discos_Brendon_Urie_Comes_Out_Pansexual_Definitely_Attracted_To_Men'><p class="type-small ptxxs mtn pr5">Panic! At The Disco's Brendon Urie Comes Out Pansexual; 'Definitely' Attracted To Men               </p></a></li>

    
    <li class="col-xs-4"><a href='/article/44913/Queer_Eyes_Antoni_Porowskis_Food_Advice_For_A_Breakup_Put_Them_In_A_Food_Coma'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/antoni_queer_eye_all_things.jpg')"></div></div></div></a><a href='/article/44913/Queer_Eyes_Antoni_Porowskis_Food_Advice_For_A_Breakup_Put_Them_In_A_Food_Coma'><p class="type-small ptxxs mtn pr5">Queer Eye's Antoni Porowski's Food Advice For A Breakup: Put Them In A Food Coma                    </p></a></li>

    
    </ul>
</div>




    <div class="row im-centered hidden-xs" style="margin:auto; height:90px; max-width:728px;"><div style="background-color:#fff; width:728px; height:90px;"><div><!-- web_leaderboard -->
<!-- BEGIN JS TAG - OnTopMag Master Bottom 728x90 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231475" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>




        <div class="row im-centered hidden-sm hidden-md hidden-lg" style="margin:auto; max-width:320px;"><div  style="background-color:#fff; width:320px; height:50px;"><div><!-- BEGIN JS TAG - OnTopMag Mobi Leaderboard 320x50 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1318027" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>

    <div class="row">
 
    <table cellspacing="0" id="MainContent_FormView1" style="border-collapse:collapse;">
	<tr>
		<td colspan="2">
        
        <div class="article-headline-wrapper">
        <h1><span id="MainContent_FormView1_Label1" class="headline">Hayley Kiyoko Joins HRC's Equality Rocks Campaign                                                   </span></h1>

        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div style="margin-bottom:5px;" data-title='Hayley Kiyoko Joins HRC's Equality Rocks Campaign' class="addthis_sharing_toolbox"></div>
        
            <ul class="h5 list-inline container text-sizing-80" style="color:#a8a8a8; padding:0; list-style-type:none;">
                <li style="padding:0;">By </li>
                <li style="color: #545454; padding:0; text-transform: uppercase;">
                    
                       <span id="MainContent_FormView1_Label2">On Top Magazine Staff                             </span>       
                   </li>
                <li style="padding:0;"> |  
              <span id="MainContent_FormView1_Label3">July 07, 2018</span></li>
            </ul>

            </div>
        
           
   <div class="col-md-8">  


       <span id="MainContent_FormView1_Media"><iframe class='item-responsive col-xs-12' width='640' height='360' style='border:none; overflow:hidden;' src='http://www.youtube.com/embed/XmMIbFH6u5U?wmode=transparent' frameborder='0' allowfullscreen></iframe></span>
        <span id="MainContent_FormView1_lblBody" class="articleBody">
<p>Singer-songwriter Hayley Kiyoko is the
latest artist to join the Human Rights Campaign's (HRC) Equality
Rocks campaign.</p>
<p>“Equality Rocks is a public
engagement campaign featuring prominent musicians – both American
and international – who support lesbian, gay, bisexual, transgender
and queer equality,” the <a href="http://www.hrc.org/EqualityRocks" target="_blank">campaign's
website</a> states.</p>
<p>The 27-year-old Kiyoko came out with
her 2015 track “Girls Like Girls.”</p>
<p>“Hey, it's Hayley Kiyoko, and I
support the Human Rights Campaign, because everyone deserves the
opportunity to be themselves.  And equality rocks,” Kiyoko said in
a video released Friday.</p>
<p>Other artists who have joined the
campaign include Wilson Phillips, Portugal The Man, A Great Big
World, Megan Hilty, Daya, Brendon Urie, MUNA, the Yeah Yeah Yeahs,
Neon Trees, Florence and the Machine, Phoenix, Sara Bareilles, Tegan
and Sara, Sleater-Kinney and Animal Collective.</p>
</span>

       <!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_recommended_horizontal hidden-md hidden-lg" ></div>
 <div class="fb-comments" data-width="100%" data-mobile="auto-detect"  data-version="v2.3" data-numposts="5"></div>
          </div>
            <div class="col-md-4 hidden-xs hidden-sm">


<div height: 250px; width: 300px; background-color: white;><!-- BEGIN JS TAG - OnTopMag ROS 300x250 < - DO NOT MODIFY -->


<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231478" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div>




<div style="margin-top:30px" class="fb-page" data-href="https://www.facebook.com/ontopmag" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ontopmag"><a href="https://www.facebook.com/ontopmag">On Top Magazine</a></blockquote></div></div>


<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div style="margin-top:30px;" class="addthis_recommended_vertical"></div>

<div style="height:600px; width:300px; background-color:white;"><!-- BEGIN JS TAG - OnTopMag ROS 300x600 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1307502" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div></div>

    </td>
	</tr>
</table>


 
        
  </div>
    <div id="fb-root"></div>
<script>(function (d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=239547596064955";
    fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
    <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ontopmag" async="async"></script>
    <link href="http://fonts.googleapis.com/css?family=Crimson+Text:700" rel="stylesheet" type="text/css" />

     
            <footer class="bs-docs-footer" role="contentinfo" >
                <div class="container">
                            <div class="text-center center-block">
           
   
                <a href="https://www.facebook.com/ontopmag" target="_blank"><i id="social" class="fa fa-facebook-square fa-3x"></i></a>
	            <a href="https://twitter.com/ontopmag" target="_blank"><i id="social" class="fa fa-twitter-square fa-3x"></i></a>
	            <a href="https://plus.google.com/ontopmag" target="_blank"><i id="social" class="fa fa-google-plus-square fa-3x"></i></a>
                <a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank"><i id="social" class="fa fa-rss-square fa-3x"></i></a>
	            <a href="../../contact" target="_blank"><i id="social" class="fa fa-envelope-square fa-3x"></i></a>
</div>
                       
                    <ul class="bs-docs-footer-links text-muted">

                        <li ><a href="../../newsletter">Newsletter</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../privacy">Privacy</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../about">About</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../advertise">Advertise</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../contact">Contact</a></li>
                       
                    </ul>
 <p>&copy; 2018 On Top Media</p>
                </div>
          
            
    
</footer>
        </div>
           
       
</form>
    

 
</body>

</html>

