
<!DOCTYPE html>

<html lang="en">
<head><meta charset="utf-8" /><meta name="robots" content="default, follow" /><meta name="googlebot" content="default, follow" /><meta name="language" content="english" /><meta name="msvalidate.01" content="1CBFE669AE929C594B3B0E1BF4E454CE" /><meta name="viewport" content="width=device-width, initial-scale=1.0" /><title>
	Russell Tovey Engaged To Boyfriend Steve Brockman | On Top Magazine | LGBT News & Entertainment
</title>

   

          
        
      <script type="text/javascript">
          window.onload = function () {
              var myDiv = document.getElementById("MainContent_FormView1_lblBody");
              var myThirdPar = myDiv.getElementsByTagName("p")[3];
              var newDiv = document.createElement("div");
              newDiv.className = "adInjector";
            
              var newImg = document.createElement("img");
              newImg.src = "http://www.tqlkg.com/image-7388032-11098646-1400274404000";
              newImg.height = "250";
              newImg.width = "300";
              newImg.alt = "2Xist Shop";
              
              var newLink = document.createElement("a");
              newLink.href = "http://www.anrdoezrs.net/click-7388032-11098646-1400274404000";
              newLink.appendChild(newImg);
              newDiv.appendChild(newLink);
              myThirdPar.parentNode.insertBefore(newDiv, myThirdPar);

          }
       


      </script>
      
    <link href="../../favicon.ico" rel="shortcut icon" type="image/x-icon" /><link rel="alternate" type="application/atom+xml" title="atom" href="http://feeds2.feedburner.com/ontopmagazineheadlines" /><link href="../../Content/bootstrap.min.css" rel="stylesheet" /><link href="../../Content/Site.min.css" rel="stylesheet" />
   <script defer src="https://use.fontawesome.com/65f232d7af.js"></script>
    <script type="text/javascript" src='/Scripts/jquery-2.1.4.min.js' ></script>
    <script src='/Scripts/bootstrap.min.js' ></script>
   
    

<script>(function (i, s, o, g, r, a, m) { i.GoogleAnalyticsObject = r; i[r] = i[r] || function () { (i[r].q = i[r].q || []).push(arguments) }, i[r].l = 1 * new Date(); a = s.createElement(o), m = s.getElementsByTagName(o)[0]; a.async = 1; a.src = g; m.parentNode.insertBefore(a, m) })(window, document, 'script', 'https://www.google-analytics.com/analytics.js', 'ga'); ga('create', 'UA-823485-1', 'ontopmag.com'); ga('require', 'displayfeatures')
    ga('send', 'pageview', {});</script>

<meta name="description" content="Actor Russell Tovey has announced his engagement to boyfriend Steve Brockman" /><meta name="keywords" content="gay celebrity, russell tovey, steve brockman, engaged" /><link rel="image_src" href="http://www.ontopmag.com/images/ArticleImages/russell_tovey_steve_brockman.jpg" /><meta property="og:description" content="Actor Russell Tovey has announced his engagement to boyfriend Steve Brockman" /><meta property="og:type" content="article" /><meta property="og:title" content="Russell Tovey Engaged To Boyfriend Steve Brockman" /><meta property="og:url" content="http://www.ontopmag.com/article/37366/Russell_Tovey_Engaged_To_Boyfriend_Steve_Brockman?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /><meta property="og:image" content="http://www.ontopmag.com/images/ArticleImages/russell_tovey_steve_brockman.jpg" /><meta property="og:site_name" content="On Top Magazine" /><meta property="fb:admins" content="495043790511" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@ontopmag" /><meta name="twitter:title" content="Russell Tovey Engaged To Boyfriend Steve Brockman" /><meta name="twitter:description" content="Actor Russell Tovey has announced his engagement to boyfriend Steve Brockman" /><meta name="twitter:image" content="http://www.ontopmag.com/images/ArticleImages/russell_tovey_steve_brockman.jpg" /><meta name="twitter:url" content="http://www.ontopmag.com/article/37366/Russell_Tovey_Engaged_To_Boyfriend_Steve_Brockman?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed:+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" /></head>
<body>

 

    <form method="post" action="./Russell_Tovey_Engaged_To_Boyfriend_Steve_Brockman?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3a+OnTopMagazineHeadlines+(On+Top+Magazine+Headlines)" id="ctl01">
<div class="aspNetHidden">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />
</div>

<div class="aspNetHidden">

	<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="2173C2F0" />
	<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="ACdk5GysmsfOnz4oTSN27xFkupdiZrsrAHFIzEDYFw0JFoZ5s7pr72Wcluu3HdFwL0BvCtVQgRBvsGsO+WI96nUnY1LF//qwJSFNKMiq6vrl1sa69GbT3QMAa/eThZe2+EXpBLD3XD0A6/2HxBcmQN9tnWMZI+nyWyTjOA==" />
</div>





<nav class="navbar navbar-default navbar-fixed-top" role="navigation">
    <div class="container-fluid">
    <!-- Brand and toggle get grouped for better mobile display -->
    <div class="navbar-header ">
      <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar-collapse-1">
        <span class="sr-only">Toggle navigation</span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </button>

    <a id="HomeLink" class="navbar-brand" href="../../default.aspx"><img src="../../Images/Icons/otm6_new_logo_3px_border_150.png" alt="" /></a>
    </div>
        

    <!-- Collect the nav links, forms, and other content for toggling -->
    <div class="collapse navbar-collapse" id="navbar-collapse-1">



      <ul class="nav navbar-nav ">
        <li><a href="../../section/news">News</a></li>
        <li><a href="../../section/entertainment">Entertainment</a></li>
        <li><a href="../../section/travel">Travel</a></li>
        <li><a href="../../section/features">Features</a></li>
        <li class="dropdown">
          <a href="#" class="dropdown-toggle" data-toggle="dropdown">More <b class="caret"></b></a>
          <ul class="dropdown-menu">
            <li><a href="../../tags/marriage%20equality">Marriage Equality</a></li>
            <li><a href="../../tags/donald%20trump">Trump</a></li>
            <li><a href="../../tags/pride">LGBT Pride</a></li>
            <li><a href="../../tags/homophobia">Homophobia</a></li>
            <li><a href="../../tags/transphobia">Transphobia</a></li>
            <li class="divider"></li>
              <li><a href="https://www.facebook.com/ontopmag" target="_blank">Facebook</a></li>
              <li><a href="https://www.twitter.com/ontopmag" target="_blank">Twitter</a></li>
              <li><a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank">RSS</a></li>
            <li class="divider"></li>
            <li><a href="../../newsletter">Newsletter</a></li>
            <li><a href="../../privacy">Privacy policy</a></li>
              <li><a href="../../about">About us</a></li>
              <li><a href="../../contact">Contact us</a></li>
              <li><a href="../../advertise">Advertise</a></li>

          </ul>
        </li>
   
      </ul>

        
      <div class="navbar-form navbar-right" role="search">
          <div class="form-group">
 <input name="ctl00$txtSearch" type="text" value="Search" id="txtSearch" class="form-control navbar-input" title="Search by keyword" />
 </div><a id="lnkSearch" class="btn btn-default" href="javascript:__doPostBack(&#39;ctl00$lnkSearch&#39;,&#39;&#39;)"><i class="glyphicon glyphicon-search"></i></a>
 
     
 </div> 
           		        
    </div><!-- /.navbar-collapse -->

    </div><!-- /.container-fluid -->
</nav>
     
    




        <div class="container body-content">
            
 
<div class="row">
<ul class="latestDSK list-inline hidden-xs ">

    <li class="col-sm-2"><a href='/article/37367/Kansas_GOP_OKs_Resolution_Opposing_Efforts_To_Validate_Transgender_Identity'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/kansas_gop_logo.jpg')"></div></div></div></a><a href='/article/37367/Kansas_GOP_OKs_Resolution_Opposing_Efforts_To_Validate_Transgender_Identity'> <p class="type-small ptxxs mtn pr5">Kansas GOP OKs Resolution Opposing Efforts To 'Validate Transgender Identity'                       </p></a></li>

    
    <li class="col-sm-2"><a href='/article/37365/Gus_Kenworthy_Being_Out_In_Pyeongchang_Is_Greater_Reward_Than_Medaling_In_Sochi'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/gus_kenworthy_cbs_feb_2018.jpg')"></div></div></div></a><a href='/article/37365/Gus_Kenworthy_Being_Out_In_Pyeongchang_Is_Greater_Reward_Than_Medaling_In_Sochi'> <p class="type-small ptxxs mtn pr5">Gus Kenworthy: Being Out In Pyeongchang Is Greater Reward Than Medaling In Sochi                    </p></a></li>

    
    <li class="col-sm-2"><a href='/article/37364/South_Carolina_GOP_Bill_Would_Classify_Gay_Unions_As_Parody_Marriages'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/steven_long_south_carolina_feb_2018.jpg')"></div></div></div></a><a href='/article/37364/South_Carolina_GOP_Bill_Would_Classify_Gay_Unions_As_Parody_Marriages'> <p class="type-small ptxxs mtn pr5">South Carolina GOP Bill Would Classify Gay Unions As 'Parody Marriages'                             </p></a></li>

    
    <li class="col-sm-2"><a href='/article/37363/Gavin_Grimm_Cannot_Stop_Speaking_Out_Because_Transgender_Lives_Are_On_The_Line'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/gavin_grimm_feb_2018_time_to_thrive.jpg')"></div></div></div></a><a href='/article/37363/Gavin_Grimm_Cannot_Stop_Speaking_Out_Because_Transgender_Lives_Are_On_The_Line'> <p class="type-small ptxxs mtn pr5">Gavin Grimm: Cannot Stop Speaking Out Because Transgender Lives Are On The Line                     </p></a></li>

    
    <li class="col-sm-2"><a href='/article/37362/Adam_Rippon_Declines_NBC_Winter_Olympics_Correspondent_Position'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/adam_rippon_2018.jpg')"></div></div></div></a><a href='/article/37362/Adam_Rippon_Declines_NBC_Winter_Olympics_Correspondent_Position'> <p class="type-small ptxxs mtn pr5">Adam Rippon Declines NBC Winter Olympics Correspondent Position                                     </p></a></li>

    
    <li class="col-sm-2"><a href='/article/37361/Gus_Kenworthy_Matt_Wilkas_Share_Kiss_On_Live_Olympic_TV'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/gus_kenworthy_matt_wilkas_kiss_olympics_2018.jpg')"></div></div></div></a><a href='/article/37361/Gus_Kenworthy_Matt_Wilkas_Share_Kiss_On_Live_Olympic_TV'> <p class="type-small ptxxs mtn pr5">Gus Kenworthy, Matt Wilkas Share Kiss On Live Olympic TV                                            </p></a></li>

    </ul>
    <ul class="latestDSK list-inline hidden-sm hidden-md hidden-lg">


    <li class="col-xs-4"><a href='/article/37367/Kansas_GOP_OKs_Resolution_Opposing_Efforts_To_Validate_Transgender_Identity'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/kansas_gop_logo.jpg')"></div></div></div></a><a href='/article/37367/Kansas_GOP_OKs_Resolution_Opposing_Efforts_To_Validate_Transgender_Identity'><p class="type-small ptxxs mtn pr5">Kansas GOP OKs Resolution Opposing Efforts To 'Validate Transgender Identity'                       </p></a></li>

    
    <li class="col-xs-4"><a href='/article/37365/Gus_Kenworthy_Being_Out_In_Pyeongchang_Is_Greater_Reward_Than_Medaling_In_Sochi'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/gus_kenworthy_cbs_feb_2018.jpg')"></div></div></div></a><a href='/article/37365/Gus_Kenworthy_Being_Out_In_Pyeongchang_Is_Greater_Reward_Than_Medaling_In_Sochi'><p class="type-small ptxxs mtn pr5">Gus Kenworthy: Being Out In Pyeongchang Is Greater Reward Than Medaling In Sochi                    </p></a></li>

    
    <li class="col-xs-4"><a href='/article/37364/South_Carolina_GOP_Bill_Would_Classify_Gay_Unions_As_Parody_Marriages'><div class="photo-component"><div class="photo-container photo-container-16x9"><div class="photo-fill" style="background-image: url('http://www.ontopmag.com/images/ArticleImages/steven_long_south_carolina_feb_2018.jpg')"></div></div></div></a><a href='/article/37364/South_Carolina_GOP_Bill_Would_Classify_Gay_Unions_As_Parody_Marriages'><p class="type-small ptxxs mtn pr5">South Carolina GOP Bill Would Classify Gay Unions As 'Parody Marriages'                             </p></a></li>

    
    </ul>
</div>




    <div class="row im-centered hidden-xs" style="margin:auto; height:90px; max-width:728px;"><div style="background-color:#fff; width:728px; height:90px;"><div><!-- web_leaderboard -->
<!-- BEGIN JS TAG - OnTopMag Master Bottom 728x90 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231475" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>




        <div class="row im-centered hidden-sm hidden-md hidden-lg" style="margin:auto; max-width:320px;"><div  style="background-color:#fff; width:320px; height:50px;"><div><!-- BEGIN JS TAG - OnTopMag Mobi Leaderboard 320x50 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1318027" TYPE="text/javascript" ></SCRIPT>
<!-- END TAG --></div></div></div>

    <div class="row">
 
    <table cellspacing="0" id="MainContent_FormView1" style="border-collapse:collapse;">
	<tr>
		<td colspan="2">
        
        <div class="article-headline-wrapper">
        <span id="MainContent_FormView1_Label1" class="headline">Russell Tovey Engaged To Boyfriend Steve Brockman                                                   </span>

        <!-- Go to www.addthis.com/dashboard to customize your tools -->
        <div style="margin-bottom:5px;" data-title='Russell Tovey Engaged To Boyfriend Steve Brockman' class="addthis_sharing_toolbox"></div>
        
            <ul class="h5 list-inline container text-sizing-80" style="color:#a8a8a8; padding:0; list-style-type:none;">
                <li style="padding:0;">By </li>
                <li style="color: #545454; padding:0; text-transform: uppercase;">
                    
                       <span id="MainContent_FormView1_Label2">On Top Magazine Staff                             </span>       
                   </li>
                <li style="padding:0;"> |  
              <span id="MainContent_FormView1_Label3">February 20, 2018</span></li>
            </ul>

            </div>
        
           
   <div class="col-md-8">  


       <span id="MainContent_FormView1_Media"><img class='img-responsive col-xs-12' src='http://www.ontopmag.com/images/ArticleImages/russell_tovey_steve_brockman.jpg'/></span>
        <span id="MainContent_FormView1_lblBody" class="articleBody">
<p style="margin-bottom: 0in">Actor Russell Tovey has announced his
engagement to boyfriend Steve Brockman.</p>
<p style="margin-bottom: 0in">The 36-year-old Tovey confirmed the
happy news on Monday.</p>
<p style="margin-bottom: 0in">“Completely unexpected but very, very
happy and looking forward to having a proper party to celebrate when
back in London,” <a href="http://www.dailymail.co.uk/tvshowbiz/article-5410249/Being-Human-actor-Russell-Tovey-announces-engagement.html" target="_blank">Tovey
told the MailOnline</a>.</p>
<p style="margin-bottom: 0in">Tovey and Brockman, a rugby coach, are
thought to have begun dating in 2016.</p>
<p style="margin-bottom: 0in">Tovey currently plays Harry Doyle on
the ABC drama <i>Quantico</i> and the voice of gay superhero The Ray
on the CW Seed's animated series <i>Freedom Fighters: The Ray</i>.</p>
<p style="margin-bottom: 0in">In 2013, the British actor, who came
out as a teenager, took on his first major gay role, playing Kevin in
the HBO dramedy <i>Looking</i>.</p>
<p style="margin-bottom: 0in">Last year, he told <i>The Guardian</i>
that taking on gay roles “wasn't a conscious decision.”</p>
<p style="margin-bottom: 0in">“And it was only the other day that I
realized it had been important somehow.  For so long, as a young
actor, I had this anxiety about making sure I could get straight
roles, and now I know that's not necessary,” he said.</p>
<p style="margin-bottom: 0in">“The gay roles are the best for me. 
Being gay has made my career,” he added.</p>
</span>

       <!-- Go to www.addthis.com/dashboard to customize your tools -->
<div class="addthis_recommended_horizontal hidden-md hidden-lg" ></div>
 <div class="fb-comments" data-width="100%" data-mobile="auto-detect"  data-version="v2.3" data-numposts="5"></div>
          </div>
            <div class="col-md-4 hidden-xs hidden-sm">


<div height: 250px; width: 300px; background-color: white;><!-- BEGIN JS TAG - OnTopMag ROS 300x250 < - DO NOT MODIFY -->


<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1231478" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div>




<div style="margin-top:30px" class="fb-page" data-href="https://www.facebook.com/ontopmag" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/ontopmag"><a href="https://www.facebook.com/ontopmag">On Top Magazine</a></blockquote></div></div>


<!-- Go to www.addthis.com/dashboard to customize your tools -->
<div style="margin-top:30px;" class="addthis_recommended_vertical"></div>

<div style="height:600px; width:300px; background-color:white;"><!-- BEGIN JS TAG - OnTopMag ROS 300x600 < - DO NOT MODIFY -->
<SCRIPT SRC="http://tag.gayadnetwork.com/ttj?id=1307502" TYPE="text/javascript"></SCRIPT>
<!-- END TAG --></div></div>

    </td>
	</tr>
</table>


 
        
  </div>
    <div id="fb-root"></div>
<script>(function (d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.4&appId=239547596064955";
    fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
    <!-- Go to www.addthis.com/dashboard to customize your tools -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ontopmag" async="async"></script>
    <link href="http://fonts.googleapis.com/css?family=Crimson+Text:700" rel="stylesheet" type="text/css" />

     
            <footer class="bs-docs-footer" role="contentinfo" >
                <div class="container">
                            <div class="text-center center-block">
           
   
                <a href="https://www.facebook.com/ontopmag" target="_blank"><i id="social" class="fa fa-facebook-square fa-3x"></i></a>
	            <a href="https://twitter.com/ontopmag" target="_blank"><i id="social" class="fa fa-twitter-square fa-3x"></i></a>
	            <a href="https://plus.google.com/ontopmag" target="_blank"><i id="social" class="fa fa-google-plus-square fa-3x"></i></a>
                <a href="http://feeds.feedburner.com/OnTopMagazineHeadlines" target="_blank"><i id="social" class="fa fa-rss-square fa-3x"></i></a>
	            <a href="../../contact" target="_blank"><i id="social" class="fa fa-envelope-square fa-3x"></i></a>
</div>
                       
                    <ul class="bs-docs-footer-links text-muted">

                        <li ><a href="../../newsletter">Newsletter</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../privacy">Privacy</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../about">About</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../advertise">Advertise</a></li>
                        <li > &middot; </li>
                        <li ><a href="../../contact">Contact</a></li>
                       
                    </ul>
 <p>&copy; 2018 On Top Media</p>
                </div>
          
            
    
</footer>
        </div>
           
       
</form>
    

 
</body>

</html>

